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Chapter 1  
Introduction to LogCheck 

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Understand what LogCheck does. 

� Understand the LogCheck user interface philosophy. 

� Understand the features of LogCheck. 
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1.1  What is LogCheck? 

LogCheck is a Windows-based system for the management of coal exploration data. It has been 

designed and written by experienced coal geologists who understand their colleagues' needs. It 

includes facilities for: 

• data entry, validation, plotting and production of English reports for hole header 

(location information), drilling, water flow, downhole geological and geotechnical (rock 

mass unit, defect and point load) data, 

• plotting of downhole geophysical data, 

• import and export of dictionaries and data to and from geological databases and 

modelling packages, such as Acquire, Geobank, MineScape (GDB), Vulcan, Minex and 

Englog, 

• production of various audits and summaries, including summaries of: data currently 

stored for each hole; dictionary code usage; drilling meterage; seams, horizons and 

samples in each hole; contents of downhole geophysical (LAS) files; rock mass unit 

characteristics and point load indices. 

 

It complements geological database and modelling packages such as Acquire, Geobank, 

MineScape (GDB), Vulcan and Minex by providing a system: 

• with comprehensive validation facilities, 

• which is extremely easy to learn with a user interface similar to other Windows 

programs such as Excel and thus easily picked up by short term geological contractors 

employed during drilling programs, 

• does not tie up an expensive mining package licence for data entry, 

• enables the plotting, in numerous different formats, of any of the data variables stored in it. 

 

1.2 History of LogCheck 

LogCheck evolved from a DOS-based system called LogBase. This was first developed in 1995 

to facilitate the entry and validation of lithology data by coal geologists. It then expanded into 

generating graphics and providing entry and validation of geotechnical data. 

In 2002, the system was rewritten into the Microsoft Windows environment and renamed 

LogCheck. It currently has over 200 users at over 60 sites, chiefly in Australia, but also in 

Indonesia, Russia and Mongolia. 
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1.3 LogCheck’s User Interface Philosophy 

LogCheck  has a relatively simple user interface, making it very appropriate for use by short-

term contracting staff who are not on site long enough to warrant lengthy tuition.  

The simplicity of LogCheck’s user interface is based on an “object oriented approach”. This is 

one of the current buzz words in computing. In LogCheck’s case, it means that there is always a 

particular set of data open (the “object” in computer jargon) and LogCheck’s menus change 

according to the current data to reflect the actions (the “methods” in computer jargon) that can 

be performed on that data. 

Apart from offering options for all these actions, the menus also provide options to create a new 

data table for a new hole or open another data set. 

 

1.4 LogCheck Data Sets 

LogCheck data sets fall into five general categories: 

1. Dictionary data: Dictionaries contain codes and their user-defined meanings. A 

dictionary is required for each hole data type (see below). 

Dictionaries can be imported, entered, modified, printed, 

exported and plotted as a symbol legend. 

2. Project data:  Includes the project title to appear on reports, plots etc; 

rectangular coordinate limits for the project; survey coordinate 

grid type etc. Can be entered and modified by the user. 

3. Hole data: There is a separate file for each data type for each hole. Current 

data types include: Headers, Cementing, Casing, Geologists, 

Drilling, Geology, Water Flows, Coal Quality, LAS (downhole 

geophysical), Rock Mass Units and Defects, Point Loads, 

Uniaxial Compressive Strengths (UCS) and Acoustic Scanner 

Analyses. Hole data can be imported, entered, modified, 

printed, plotted and exported. The only exception to this is that 

LAS data cannot be entered or modified via the keyboard. 

4. Audit, statistical and  It includes Project Audits, Hole Audits, Hole Summaries, 

summary data:  Seam Summaries, Sample Summaries etc. This data is 

   generated from the hole data. It can be viewed, exported and 

   printed but not modified. 

5. Program control data: This is data that is used by the program when opening or 

plotting data. It includes definitions for Hole Sets, Hole 

Intervals, Hole Plans, Downhole Plots, Histograms and 

Graphical Editor. This data can only be entered and modified. 
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1.4.1 Data Audits  

LogCheck generates a number of data audits that are useful for managing your data. These include 

the following audits: 

• Dictionary showing for each code in the dictionary, the number of times it has been used in 

the data and the names of the first and last holes where it has been used; 

• Codes showing where a specified code has been used in the data; 

• Projects showing the number of holes for each data type within each project; 

• Total depths showing the final depth (or blank if no data present) for each data type for 

each hole; 

• Uncorrelated Coals showing each seam defined in the hole and any occurrences of coal not 

yet assigned a seam name, that occurs between these seams; 

• Unsampled Coals showing any coals that do not have sample numbers; 

• Unsampled Seams showing any parts of a seam that do not have a sample number; 

• Horizons showing for each hole, the depth of the various horizons such as base of weathering; 

• Strats showing for each hole, the thickness of the various stratigraphic units encountered in it; 

• Seams showing for each hole, the thickness of the various seams encountered in it; 

• Plies showing for each hole, the thickness of the various plies encountered in it; 

• LAS Files showing for each LAS file its: hole name, date logged, logging company, 

reading spacing, top and bottom depths and recorded geophysical variables (as defined in 

the header of the LAS file). 

1.4.2 Data Summaries 

LogCheck generates data summaries that are useful for reviewing your data. These include the 

following summaries: 

• Drilling showing the start and end date of drilling and the number of metres of each 

drilling type in each hole; 

• Seam/Horizon Picks showing for each horizon, stratigraphic, seam or ply unit in each hole, 

its from and to depth and thickness; 

• Seams/Plies showing for each seam or ply in each hole: the depth and elevation of its top 

and bottom, its thickness, the thickness of coal partings and core loss in the seam, the 

thickness of either interburden to the seam above, or overburden to the surface, the 

stripping ratio and the cumulative stripping ratio; 

• Samples showing for each sample in each hole: its sample number, top and bottom depths, 

top and bottom seams and plies, theoretical mass and lithology; 

• Seam/Ply Composites showing for each seam or ply in each hole: seam, from/to depth 

thickness, sample number, and the composite analysis results for total moisture, ash, 

volatile matter, fixed carbon, specific energy, calorific value, total sulphur, phosphorous 

and chlorine, as derived by compositing the results from individual samples. 

• Defects showing for each core run or Rock Mass Unit (RMU) as defined by the geologist:  

- the rock mass data such as RMU type, weathering, slaking potential, strength, bedding 

development and mechanical state;  

- the RQD, Hansagi's C Factor, average stick length, fracture frequency, rock mass 

rating (RMR), Q-index, minimum / maximum defect angle and minimum / maximum 

defect direction. These are all calculated from the individual defect data; 
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- the most common: defect type, origin, continuity, width, infill mode, infill type, infill 

consistency, surface shape and surface roughness within the core run or RMU; 

• Defect Spacings showing for each defect the distance to the defect above it; 

• Fracture Frequency showing for each defect a fracture frequency value from the defect 

above to the defect below; 

• Point Load Indices showing the calculated point load index for each test sample; 

All data summaries can be listed either as reports or delimited format for output to word 

processing or spread sheet packages. Data from the non-geotechnical summaries can be plotted 

on hole plans and data from the geotechnical summaries can be plotted as downhole plots. 

1.4.3 Statistics 

LogCheck generates statistical reports for the following: 

• Coded Data Frequencies showing for each hole, the frequency of occurrence of a specified 

dictionary variable – for example, the number of times each lithology occurs in each hole or the 

thickness of each lithology in each hole; 

• Interval Thickness Statistics showing for each hole, the mean, standard deviation, minimum 

and maximum of the thickness of the coal intervals in each hole; 

• LAS Variable Statistics, including for each variable in each hole, or specified part of a 

hole, its mean, standard deviation, minimum, maximum and various percentile values. 

Coded Data Frequencies can be plotted as histograms and LAS Variable Statistics can be plotted 

as box and whisker plots. 

 

1.5 Features of LogCheck 

Some of the features of LogCheck include: 

• data entry and editing, 

• data listings, 

• data plotting, 

• graphical editing. 

 

1.5.1 Data Entry & Editing 

LogCheck supports a number of widely used data sheet formats or can be tailored to match the 

client’s specific needs. Data can be imported from Geobank, Acquire, MineScape (GDB), 

Vulcan, Minex, Excel .csv or Englog text files or entered directly.  No matter which method is 

chosen to enter data, it is fully validated before it is accepted into the system. This includes 

checking that depths are in sequence, compulsory fields such as lithotype are entered, 

percentages of lithologies add up to 100% and pneumonic codes are contained in the dictionary.  
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The data editor includes facilities to: 

• display the data in grid (like a spreadsheet) or forms (single page per record) format, 

• hide certain fields when not required, 

• select codes from a menu of valid codes, 

• edit English comments using a word processing style editor, 

• automatically copy down values of user specified fields onto new lines, 

• insert, delete and undelete records, 

• search and replace fields, 

• add or subtract a constant value to a set of depths, 

• expand or contract a set of depths to account for core loss / expansion. 

 

The LogCheck editor is shown below: 

 

 
 

 

 
 

1.5.2 Data Listings 

Data can be listed in its original format or as reports with codes converted to full English 

descriptions. In either case, the listings can be produced either as PDF’s or text files for 

importing to other software such as Excel or Word. They can be generated for part of a hole, a 

single hole, a set of holes or all holes in the project. Report formats can be tailored to suit the 

client’s requirements. 
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An example of a coded data report that has been generated as a PDF file is as follows: 

 

 

 

An example of a geology report is as follows: 
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1.5.3 Graphical Editing 

The Graphical Editor (GeoEdit) is used for graphically displaying hole data, and aligning depths 

of lithologies with the downhole geophysics. GeoEdit reads data from a hole log generated from 

LogCheck, and displays the lithology, seam, ply, sample number, mechanical state and 

geophysics in a graphical format. The main editing operations are: 

• Moving the From depth of an interval(s) either further down or up the hole,  

• Inserting a new interval at the top, bottom or within existing units, 

• Expanding or contracting units, either by a single group or a set of tie lines, 

• Renaming a lithology, seam, ply or sample number. 

 

It maintains a history of edits done during the current session, and allows you to undo each edit. 

A log of these edits is saved to a text file. Also, the first time that GeoEdit is invoked for a given 

hole, a raw copy of the data is saved. An example of a hole displayed in GeoEdit before depth 

corrections on the left and after depth corrections on the right, is shown below: 
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1.5.4 Data Plotting 

Plots are generated as industry standard .dxf files which can be displayed, edited and/or plotted 

from nearly any CAD package – for example, AutoCAD’s TrueView, which is available for 

free. TrueView can be used to view or output a plot, however it does not have the ability to edit 

the plot. LogCheck produces four types of plots:  

• drill hole location plans which can also show seam information such as coal thickness, 

parting thickness and strip ratios; 

• downhole plots of any combination of geological, geotechnical and/or geophysical data for 

part of a hole, a single hole or a set of holes along a section; 

• histograms that graph the frequency of occurrence of a variable; 

• box and whisker plots showing the ranges and average values of geophysical data within 

each hole. 

In the case of downhole plots, lithological data can be displayed as symbols using the supplied 

symbol set or you can design your own. Defects can be displayed as planar, stepped or curvy 

angled lines. Coded data can be displayed as codes (optionally staggered horizontally based on 

their value), English descriptions or histograms (say, for rock strength). Numeric data can be 

displayed as traces (lines joining point to point), histograms or numbers. You can either use one 

of LogCheck’s standard sheet layouts for plotting downhole data or design your own.  

An example of a plot generated by LogCheck and displayed in TrueView is shown below: 
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1.6 LogCheck Availability 

LogCheck is available for outright purchase or rent on a shorter-term basis. Maintenance and 

Support is free for the first twelve months after purchase after which it is charged annually at 

15% of the current purchase price. For further information, contact one of the following 

personnel listed in the following table. 

 

Contact    For    Details    

Brett 

Larkin  Inquiries from New South Wales. 
Email: brett@geocheck.com.au  

Ph/Fax: +61 2 4385 4829  

Mob: +61 4 2723 2264  

Gary 

Ballantine  Inquiries from Mongolia. Email: gary@geocheck.com.au  

Mob: +61 4 4753 5041  

Gamal 

Jacob  Inquiries from Indonesia. Email: gamal@geocheck.com.au  

Mob: +62 812 1850 1850 

Graeme 

Hewitt  
Inquiries from Queensland and 

elsewhere. 
Email: graeme@geocheck.com.au  

Ph/Fax: +61  7 5455 4680   

Mob: +61 4 2916 7688 

 

1.7 Glossary of Computer Terms 

The following chapters assume that you are familiar with database terminology, including: 

• ASCII Text: ASCII is a code for representing English characters as numbers, with 

each letter assigned a number from 0 to 127. For example, the ASCII 

code for upper case A is 65. 

• Column: A column on the screen showing the value of a field over a number of 

records. 

• CSV File: A CSV (comma separated values) file consists of a text file where data 

values are separated by commas; it is used for transferring data 

between applications. 

• Database: A set of inter-related tables that is held in persistent storage. For 

example, the LogCheck database of drill hole data. 

• DBMS: A database management system is the software that maintains the data 

in a database. 

• Field:  A discrete value in a record, for example the lithology for an 

individual interval of a particular hole.  

• File: A container for storing data on a computer’s disk drive, for example, 

the geology data for a drill hole is held in a single file. 
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• File Type:  The extension on the end of a file name that indicates to the computer’s 

operating system the kind of data stored in the file. For example, a file 

extension of .dbf indicates that it is a dBASE database file. 

• Folder/ A file structure that stores other files, for example, C:\Logdata. 

Directory  The terms folder and directory are interchangeable. 

• Index:  An ancillary data structure to a table that sorts the record in the table, 

for example, each dictionary has an index file attached to it so that it 

can be displayed in order. 

• Primary key:  A field in a table that uniquely identifies each record, for example, the 

sample number on a set of proximate analysis results. 

• Query:  A subset of a table that satisfies a set of criteria. 

• Record:  Composed of a related group of fields. For example, all the proximate 

analysis results for a single sample. 

• Row:  A record as displayed on the screen. 

• Tab delimited A text file where data values are separated by tabs.  

file:  

• Table:  Stores information about an entity, such as a drill hole, in a structure 

that is composed of records containing fields. 

• Validation rules:  Specify the criteria that are acceptable before data is entered in a field. 

• Variable: A cell in computer memory that can store a single value. 

 

 

 

1.8 Acronyms 

 

AMG Australian Mapping Grid 

ASCII American Standard Code for Information Interchange 

LAS Log ASCII Standard 

MGA Mapping Grid of Australia 

RMR Rock Mass Rating 

RMU Rock Mass Unit 

UCS Uniaxial Compressive Strength. 

 

 

. 
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By the end of this chapter you will be able to: 

 

� Install the dBase RunTime. 

� Install and start LogCheck. 

� Install Multiple Versions of LogCheck on a single computer. 

� Install optional components. 

� Set up the LogCheck data directory. 

� Install a dictionary. 

� Set up a new project. 

� Set the project details data. 

� Enter hole data. 
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2.1 Introduction 

This chapter explains how to install LogCheck software and commence using the software as 

quickly as possible. The steps involved are: 

• Install the dBASE Runtime if it is not already installed, 

• Install the LogCheck software, and optionally the graphical editor (GeoEdit), which 

requires the Java runtime. 

• Setup the LogCheck data directory. 

• Setup the dictionary, project details and initially enter hole data. 

 

 

2.2 Installing the dBASE RunTime Engine 

LogCheck stores user data in database files that use the dBASE format. It processes them using 

a version of dBASE that is called the dBASE Runtime Engine. The Runtime engine may be 

freely distributed and must be installed before LogCheck can be installed.  

The Runtime engine installation file is called PlusRuntime-b2215_EN.exe and is about 12.5 

MB. The program once installed takes up around 75MB. The installation program is 

downloadable from the web address: 

  http://www.dbase.com/support/updates 

 

Scroll down until the dBASE PLUS Runtimes section is encountered. Then select dBASE Plus 

Runtime Version 2.80, and double click the English Runtime Engine link from the dropdown 

box.  This program generally does not need to be upgraded each time LogCheck is upgraded. 

Occasionally, however, a LogCheck upgrade will also require an upgrade to Runtime. In which 

case, the user will at the time receive instructions on how to download the new Runtime. 

To install Runtime just double click on the installation file once you have downloaded it, 

progress through the following dialogs, accepting the default values in each case: 

 

The first dialog 

requests the language: 
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Next, the dialog on the right initiates the 

installation: 

 

 

 

 

 

 

Next, the destination folder for the 

dBASE runtime is requested, as shown in 

the the dialog on the right. 

 

 

 

 

 

Next, the destination folder for the Borland 

Database Engine (BDE) is requested, as 

shown on the right. 

 

 

 

 

 

Lastly, a confirmatory dialog is displayed 

that summarises the configuration, as 

shown on the right. 
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2.3  Installing and Starting LogCheck 

LogCheck installation files are around 10MB and can be distributed over the internet using file 

distribution software such as YouSendIt. This sends the receiver an email that has a link to a 

web address from which the LogCheck install file can be downloaded. 

The installation file for LogCheck has a name in the form lcn.nnndataformat.exe where n.nnn is 

the release number and dataformat is the particular format used for recording geological data in 

that copy of LogCheck. For example, the installation file lc6.002CoalLog.exe will install release 

6.002 of LogCheck and uses a CoalLog format for the data. 

To install LogCheck double click on the installation file. The following screen should then 

appear: 

 

 

 

 

 

 

 

 

 

 

 

Screens will then appear prompting for: 

• where to store the program,  

• where to include it on the start menu and  

• if you would like an icon for it on the desktop.  

 

It is preferable but not necessary to choose the defaults when prompted for this information. 

Once installed, to start LogCheck, double click on the icon (as shown below) on your desktop. 
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2.4 Installing Multiple Versions of LogCheck 

 on a Single Computer 

Some users with a number of clients with different data formats may need to have multiple 

versions of LogCheck on their computer. To install a second copy of LogCheck, first determine 

the directory where the current version is installed. If the default was chosen during the 

installation process this will be c:\Program Files (x86)\LogCheck for the 64-bit version of 

Windows, and C:\Program Files\LogCheck for the 32-bit version of Windows. 

Now when installing the second version 

of LogCheck and the window to the 

right appears: 

Enter a different directory name to the 

first, for example, if the first is called: 

 
  C:\Program Files (x86)\LogCheck 
 

the second could be called: 

 
  C:\Program Files (x86)\LogCheck CoalLog 
 

If this new directory name does not exist 

the installation program will create it. 

Then progress through the installation 

windows by selecting the Next buttons.  

 

On installing the second version of LogCheck, the desktop icon for the first version will be 

overwritten by the icon for the second version. To recreate a desktop icon for the first, perform 

the following steps: 

1) Go to the desktop and single click with the right-hand mouse button on the LogCheck icon 

2) Select Copy from the popup menu, 

3) Point the cursor to the place on the desktop where you want to place the second icon and 

then single click with the right-hand mouse button, 

4) Select Paste from the popup menu. 
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There should now be two LogCheck icons on the 

screen and both will start the second version of 

LogCheck. To set one to point to the first version 

perform the following steps: 

1) Select which icon should be modified to start 

the first version of LogCheck and single click 

with the right-hand mouse button on this icon, 

2) Select Properties from the popup menu. An 

icon properties window like the one on the 

right should appear. This window would look 

slightly different on computers running 

Windows XP, 

3) Select the General tab from the properties 

window and change the icon name in the top 

box to whatever is appropriate, for example 

LogCheck Geodas: 

 

 

 

 

 

 

 

 

 

4) Select the Shortcut tab from the properties 

window and set the Target to the initial 

version of LogCheck including its full path 

name. If there are any blanks in the path or 

file name then the full path and file name 

need to be enclosed in double quotation 

marks:  
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5) The icon can be changed by selecting the “Change Icon…” 

button. After which the window to the right appears: 

To change the icon, select the appropriate icon from the 

displayed list and then select OK. If none of those 

displayed suit, further icons can generally be found in the 

files moricons.dll, pifmgr.dll and shell32.dll in the 

Windows System32 folder. If the name of the file in which 

icons can be found is changed the new ones are not 

displayed until clicking on the box containing the icons; 

6) Once satisfied with the icon, its name and its target, click 

on the OK button on the LogCheck Properties window. 

After making the appropriate changes to the icon for the first 

version, any changes to the icon type and name for the second 

version can be made using the same steps as described above. 

 

2.5 Installation of Optional Components 

The LogCheck  installation program may also optionally install driver software for dongles. If 

your licence also includes GeoEdit, then it is also automatically installed. In this case, you will 

also need to have the Java runtime environment installed – this is usually already installed on 

most computers. 

To determine if Java is installed, open Windows Explorer and navigate to C:\Program Files, or 

C:\Program Files (x86) for Windows 64-bit operating system. If there is a folder there named 

Java, then it has already been installed. If Java is not installed, go to the following web address 

for a free download: 

  http://java.com/en/download/ 

 

2.6 LogCheck Data 

LogCheck data falls into five general categories: 

1. Dictionary data: Dictionaries contain codes and their user-defined meanings. A 

dictionary is required for each hole data type (see below). 

Dictionaries can be imported, entered, modified, printed, 

exported and plotted as a symbol legend. 

2. Project data:  Includes the project title to appear on reports, plots etc; 

rectangular coordinate limits for the project; survey coordinate 

grid type etc. Can be entered and modified by the user. 

3. Hole data: There is a separate file for each data type for each hole. Current 

data types include: Headers, Cementing, Casing, Geologists, 

Drilling, Geology, Water Flows, Coal Quality, LAS (downhole 

geophysical), Rock Mass Units and Defects, Point Loads, 

Uniaxial Compressive Strengths (UCS) and Acoustic Scanner 

Analyses. 
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4. Audit, statistical and  It includes Project Audits, Hole Audits, Hole Summaries, 

summary data:  Seam Summaries, Sample Summaries etc. This data is 

   generated from the hole data. It can be viewed, exported and 

   printed but not modified. 

5. Program control data: This is data that is used by the program when opening or 

plotting data. It includes definitions for Hole Sets, Hole 

Intervals, Hole Plans, Downhole Plots, Histograms and 

Graphical Editor. This data can only be entered and modified. 

Data entered into LogCheck is of three basic types: 

• Numerical data, such as a hole depth, hole coordinates and coal quality results. 

• Character string data, such as hole names and sample numbers. 

• Coded data that is chosen from a dictionary, such as lithotypes and grain size. 

 

2.7 Setting up the LogCheck Data Directory 

The first time that LogCheck is started the 

window to the right prompts for the name of the 

drive and directory where data is to be stored: 

To accept the default, click the OK button. 

However, if the data is to be stored in another 

location, you can either type in the path, or click 

the Browse button to navigate to the required 

folder. 

 

As the prompt states, the directory will be 

created if it does not exist. It can later be 

changed by selecting Settings > Options from 

LogCheck’s menu. It is possible to have more 

than one such data directory but LogCheck will 

only see data in whichever one is the current 

one. Even when running multiple versions of 

LogCheck for different clients it is not 

necessary to set up multiple data directories as 

all projects can be stored in the one data 

directory. LogCheck though will only see those 

projects that were created using the currently 

running version. 

Multiple data directories are most useful where some LogCheck data for a project is to be stored 

locally and some on a server, for example, working data could be stored locally and finalized 

data on the server. Apart from LAS data, all LogCheck data sits in project subdirectories off a 

single data directory usually called LogData. 
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2.8 LogCheck Dictionaries 

If a LogCheck data type includes coded data, that is all data types except Cementing, Geologists, 

Coal Quality and UCS, then a dictionary of the codes is required before any data of that type 

can be entered into LogCheck. In addition, if you are using CoalLog format, before entering 

geology data, you will need a local seam dictionary as well as the CoalLog geology dictionary. 

Each dictionary consists of two files with names of the form: 

• Data Type Dictionary.dbf and  

• Data Type Dictionary.mdx.  

For example, the geology dictionary files will be called: 

Geology Dictionary.DBF a dictionary of the categories, their codes and descriptions; 

Geology Dictionary.MDX an index into the dictionary of code names. 

The following example shows the first few lines of the Lithotype category of a Geology dictionary: 

All LogCheck dictionaries contain twelve columns (these are described in detail in Chapter 3 of 

the LogCheck User Manual): 

• Code:  An abbreviation used by the geologist when entering data; 

• Desc:  The full description that the code represents. This is what will appear for the 

code in reports, and in plots where descriptions are being displayed; 

• Group:  Used to group certain dictionary entries. It is used for various purposes by 

various parts of LogCheck. For most dictionary categories it is not required 

but in the case of the Seam/Horizon category, the group is required and can 

only have the values HORIZ, SEAM and STRAT. HORIZ being a zero 

thickness unit. SEAM a non-zero thickness unit that is economic and 

STRAT a non-zero thickness unit which is non-economic; 

• Before:  A Y indicates that when the entry appears in a full English description, a 

comma should be included before the word, otherwise it is not included; 

• After:  A Y indicates that when the entry appears in a full English description, a 

comma should be included after the word, otherwise it is not included; 

• Pattern: The name of the primary pattern that will be used for plotting (see Appendix 

C of the LogCheck User Manual); 
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• Pattern2: The name of the secondary pattern for plotting – if specified, it is combined 

with the primary pattern; 

• Colour:  An AutoCAD colour number – a number between 1 and 255 (see Appendix 

E of the LogCheck User Manual); 

• Fill: The name of the fill that will be used for plotting (see Appendix D of the 

LogCheck User Manual); 

• FillColour:  An AutoCAD colour number that will be used for drawing the fill; 

• BgColour:  An AutoCAD colour number that will be used for drawing the background; 

• Comments:  Provided so that the user can enter reminder notes that they may need when 

doing dictionary housekeeping. This field is not used by LogCheck. 

 

2.8.1 Where are Dictionaries Stored? 

When LogCheck is searching for a dictionary for a particular data type it first looks in the 

directory for that data type within the current project. If it does not exist it then searches the 

directory called Dictionaries sitting in the LogCheck data directory. For example, when looking 

for the geology dictionary for the project AVOCA it would look for: 

  c:\LogData\AVOCA\Geology\Geology Dictionary.dbf 
 

and if this file does not exist it would look for: 

  c:\LogData\Dictionaries\Geology Dictionary.dbf. 

This search procedure enables the user to have a single Geology (or any other data type) 

dictionary covering most projects but have a special dictionary for a particular project. 

 

2.8.2 Setting up a Dictionary 

The simplest way to get started is to copy a LogCheck dictionary from somewhere else – for 

example, another project, or obtain one from GeoCheck Pty Ltd. Other ways to create a 

dictionary are described in Chapter 3 of the LogCheck User Manual. 

 

2.9 Setting up a New Project 

Each project has a single directory that sits in the LogCheck Data Directory. All the data, apart 

from LAS data, for a project sits in subdirectories off the project directory. These subdirectories 

are named according to the type of data they contain and are created as required by LogCheck. 

For example, when the first hole of Water Flow data is entered into LogCheck for a project, 

LogCheck automatically creates a subdirectory called WaterFlows in which the data is stored.  

New project directories can only be created by LogCheck but once created can be renamed or 

deleted using Windows Explorer. To copy the data for a project to another computer running 

LogCheck, simply copy the project directory and all its subdirectories to the LogCheck Data 

Directory on the other computer. Be aware that within each project directory there is a file 

called project.mem. This file contains the details for the project. If it is renamed or deleted 

LogCheck no longer recognizes the directory as a LogCheck project directory. 
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If no projects exist in the LogCheck 

data directory when LogCheck is 

started the warning to the right is 

displayed: 

 

 

 

Next the prompt to the right is 

displayed for a name for the initial project: 

The name for a project directory is restricted to a 

maximum of eight characters and cannot contain 

blanks. Once the project has been created 

LogCheck displays its Project Details for editing. 

Further new projects can be created at any time by 

selecting File > New > Project from LogCheck’s 

menu. 

 

2.10 Project Details Data 

Once a project is created the Project Details for the project becomes the current data set. An 

example of the Project Details for a project named AVOCA is:  
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The following is a brief description of the project data (seen Chapter 4 of the LogCheck User 

Manual for more details): 

• Project Title: This is the title for printing on reports, plots etc. The Project Title can 

contain blanks and can be of any length.  

• LAS Directory: The LAS data can reside anywhere on the user’s computer or attached 

network, unlike all the other LogCheck data, which must reside inside 

the project folder. If this field is blank, LogCheck looks for the LAS 

data in the LAS folder of the project. LogCheck will also search for 

LAS data in all lower directories under the specified folder. 

• Geodetic Datum: Currently LogCheck stores coordinates for project limits and drill 

holes as AMG’s and MGA’s. 

• Survey Format: Specifies the survey coordinate format, using the currently selected 

datum. All data is stored in grid format but can be displayed in 

longitude and latitude. 

• Depth Units: Specifies the unit of measurement that is used for editing hole data. 

Upon entering, the data is stored in metres and all reporting, plotting 

and exporting of the data is in metres. The selected depth unit is only 

displayed in the editor. This option can be changed at any time so that 

the Hole Data stored on the machine can be displayed in the required 

format. 

• Project Limits: A rectangular set of limits against which survey coordinates are 

validated.  

• UCS: Parameters specific to the project for converting sonic values to UCS 

(Uniaxial Compressive Strength). 

 

 

 

2.10.1  Opening Projects 

Where there is more than one project, to change 

between projects, go to File > Open >Project, and 

select the required project. 

Projects can also be opened from the Open Hole 

dialog (see the following chapter). 
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2.11 Creating New Data for a Hole 

Once a dictionary has been created 

for a particular data type, such data 

can be entered into LogCheck. The 

first step in this process is to create 

a new table of this data type for the 

hole by selecting File > New > 

Hole Data from the LogCheck 

menu: 

 

 

 

 

 

 

Then the dialog box shown on the 

right will appear. After selecting 

the Project, Data Type, entering the 

Hole Name for the new hole data 

and clicking OK, LogCheck will 

create the new table.  

It will be placed in the directory 

named after the data type and 

sitting in the project directory and 

uses the hole name as its filename 

with a .dbf extension. Hole names 

in LogCheck are always upper case 

and cannot contain blanks. Hole 

names are generally restricted to a 

maximum of eight characters, but can be up to sixteen characters if specifically requested. 

For example, in the case above, LogCheck will create a file named DDH001.dbf. LogCheck uses 

the hole name as its filename with a .dbf extension. If the data type directory does not exist, 

LogCheck will create it. If tables of the particular data type also contain any comment fields 

then an additional file with the same filename but extension .dbt will also be created for storing 

the comments. The files will be placed in the directory named after the data type located in the 

project directory, for example: 

    C:\LogData\AVOCA\Geology\DDH001.dbf 
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Following creation of the table, it will then be opened in the LogCheck editor, as shown below: 

 

In the above figure, the first depth of 2.00 m has been entered, and the cursor is currently in the 

Li (Lithotype) column. The Tab key moves to the next field, or the mouse can be used to select 

a column.  For those data values that have an associated dictionary, the dictionary entries are 

displayed on the right-hand side of the editor – in this example, Lithotype entries are displayed. 

Pressing the down-arrow key commences a new row. The LogCheck editor is described in more 

detail in Chapter 7 of the LogCheck User Manual. 

Hole data can be deleted, renamed or moved to another project or computer by using Windows 

Explorer. Currently the filenames of all data types for a hole are the same therefore care must be 

taken when moving files to ensure that they are placed in the directory for that data type in the 

destination project. For example, the geology data for hole DDH001 will be stored in a file 

named DDH001.dbf, in the Geology folder – the full path is as follows: 

    C:\LogData\AVOCA\Geology\DDH001.dbf 

 

The header data for the same hole has the same name, DDH001.dbf and is stored in a file named 

DDH001.dbf, in the Headers folder – the full path is as follows: 

    C:\LogData\AVOCA\Headers\DDH001.dbf 

 
Where there is a .dbf file and a corresponding .dbt file it is essential that any deletion, renaming 

or moving is applied to both files. If not, the comments for the hole may be lost.  
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Chapter 3  
Management Tools  

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Switch from general user to Manager mode. 

� Set the Manager password. 

� Understand the three levels at which LogCheck validates data. 

� Setup optional validations for geologist, drilling, geology, defect and 

point load data. 

� Create a new dictionary from scratch. 

� Copy a dictionary into a project. 

� Import a dictionary into a project. 

� Open a LogCheck dictionary in the Editor form. 

� Understand the structure of a LogCheck dictionary. 

� Understand the use of the Group column of a LogCheck dictionary. 
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3.1  Introduction  

This chapter describes management tools such as setting validation levels and options, and 

maintaining the dictionaries for a project. To access the management tools, the user needs to 

switch to Manager mode. 

3.2 The Manager Option 

The Manager option of the Settings menu allows you to switch mode from General User mode 

to Manager mode.  When in Manager mode you have privileges that allow the importing or 

modification of the dictionary, importing patterns and fills, customising data validations and 

changing the Manager password. 

 

3.2.1 Switching to Manager Mode 

Each time LogCheck is started it operates in User 

mode. To change to Manager, select Settings > 

Manager from the LogCheck menu. A prompt for 

the manager password will then appear: 

 

The default manager password is logcheck and is 

not case sensitive. 

 

 

3.2.2  Changing the Manager Password 

When in Manager mode the Settings menu 

displays an additional item, Change Password, 

that allows you to set a different Manager 

password. 

The Change Password dialog is displayed on the 

right: 

Enter the old password, enter the new password, 

then re-enter it to confirm that it is the same as 

in the previous field. 
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3.3 LogCheck Validation 

Validation is a process that verifies that the data and procedures of a system adhere to its rules. 

Validation is a general term – it can be applied to computerised and non-computerised systems 

and procedures. Validation within the software is used to validate the rules of the application. 

Prevention of errors is better than curing them. 

Validation plays a crucial role in ensuring the accuracy and integrity of the LogCheck data. 

There are three broad types of validation of input data in LogCheck: 

1) Validations performed when a field is modified: 

a. The data input by the user satisfies its fundamental type, such as validating that a 

number has the correct format for a number and that a date has a day, month and 

year in the correct order. 

b. Enforce a minimum or maximum number of characters or digits in a text field. 

For example, the number of characters in a hole name is up to 8 characters. 

c. Check the range of a value, for example, that dips are between 0 and 90 degrees. 

d. Checking that coded data, such as lithotype, is valid by checking that it is in the 

dictionary. 

2) Validations performed when the user moves between rows. These include checks for 

mandatory fields and checks where the valid value in a field depends on the values in one 

or more other fields on the same row. For example, in headers data that the hole 

completion date is not before the start date, or for drilling data that the core size is less 

than the hole size. 

3) Validations performed when the user attempts to save their data. These include checks 

which require comparing fields between rows. For example, checking that each 

successive base depth is not less than the previous base depth or where two or more 

lithotypes are specified for a unit, each has a percentage and these add up to 100%. 

Most validation checks in LogCheck are embedded in the software and cannot be turned off, 

however, there are a small number of checks in categories 2 and 3 above which the manager can 

set. 

3.4 Validation Settings 

User-specified validation settings can be accessed from the menu by going to Settings > 

Validations. In order for this menu item to appear, you need to have changed to Manager mode, 

as it is not available for the General User. There are three levels of validation: 

1. Ignore: No action is taken; 

2. Warning: A warning message is posted – the user can ignore it; 

3. Fatal: An error message is displayed and the current data item cannot be saved; 

Validation options are available for the following data: 

• Headers 

• Drilling 

• Geology 

• Defects. 
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3.4.1  Headers Tab 

The validation settings that relate to headers are displayed below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Validation settings that relate to headers are: 

• Header must exist before data can be entered for a hole: a header file must exist before other 

data, such as geology, is entered. 

• Data Total Depths must match Header Total Depth: The last base depth in the drilling, 

geologists, geology, point loads and the last RMU base depth in the defect data is compared 

to the total depth as recorded in the header. This test checks that the last base depth is equal 

to the header total depth for all these data types, except point loads where it checks that it is 

less than or equal to it. 
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3.4.2 Drilling Tab 

The validation settings that relate to drilling are: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Core Recovery Greater than 100%: This checks that core recovery in the Drilling data does 

not exceed 100%. Generally, this will be set as a warning, as the core recovery may be 

greater than 100% if there has been stick-up resulting from the previous run but the user 

should at least be warned so that they can ensure that it is not a data entry error. 

• Core Run greater than maximum Core Run: This checks that the length of a core run 

entered in the Drilling data does not exceed the value specified here as being the maximum 

core run. This is a useful check to ensure that the user has entered each separate core run. 
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3.4.3 Geology Tab 

The validation settings that relate to geology are: 

 

 

 

 

 

 

 

 

 

 

 

 

• Lithology entered on a zero thickness unit: this would be an error if the data is being 

exported to most packages, apart from Vulcan which expects a lithology on every unit 

including those with a zero-thickness. 

• Horizon occurs more than once in hole: generally you would expect horizons such as Base 

of Weathering or Base of Tertiary to only occur once in a hole. 

• Seam occurs more than once in hole: a seam should only occur once in a hole, but it should 

generally be a warning rather than fatal, as seams may be repeated if there is reverse 

faulting in a hole. 

• Seam not in stratigraphic order:  to implement this check, a Seam dictionary must first be 

created. When creating this, the seams should be entered in stratigraphic order. To perform this 

validation, LogCheck looks at the sequence of seams as they exist in the Seam dictionary. Again, 

this should generally be a warning rather than fatal, as seams may be out of order if there is 

reverse faulting in the hole. 

• Sample Number used for more than one sample in hole: a sample number 

should be only used for one contiguous set of units in a hole. Examples of 

this type of error are: 

a) It appears that 1001 has been used for more than one sample, but is 

probably the result of mis-keying 1001 as 101. 

 

 

 

b) In this example, there are gaps in the sampling, but non-contiguous 

samples are given the same sample number. This situation may exist in 

historical data, but is usually an error. 
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• Sample Number out of order: normally this will not be an error, but at some sites where 

sample books are used, this could denote a mis-keying. 

• Sample Number on Core Loss: there are two approaches here: 

a) some companies specify that a core loss should indicate a boundary 

between samples and thus does not have a sample number,  

in which case this should be set to Fatal. 

 

b) whereas others will continue a sample number across a core loss in 

which case this test should be set to ignore. In this example, two coal 

units are separated by a core loss and have both been given the same 

sample number (1001), in which case this should be set to ignore. 

 

 

 

3.4.4 Defects Tab 

The validation settings that relate to defects are displayed below:  

 

 

 

 

 

 

 

 

 

 

 

 

 

• Rock Mass Unit boundary not on a Lithological Unit boundary. A rock mass unit (RMU) is 

not the same as a lithological unit. A RMU is a unit or set of units with a common set of  

geotechnical characteristics (strength, weathering, degree of fractures, plasticity, etc). The 

general convention is that an RMU may contain multiple lithologies but a lithology may not 

contain multiple RMUs. In the rare case where a lithology unit does contain multiple RMUs 

then it should be broken up into separate lithology units. This check is most useful for 

ascertaining if the geology data for a hole has been adjusted to the geophysics but the defect 

data has not. Set the level to Fatal if this validation is required, otherwise set it to Ignore. 
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3.5 LogCheck Dictionaries 

A dictionary consists of a set of user-defined codes and their descriptions that are used to 

validate entry of drill hole data into LogCheck. This chapter describes three ways to create a 

dictionary, the data format used in a dictionary and the dictionary file structure. Editing a 

dictionary is briefly described here and in more detail in Chapter 7. 

A dictionary is required for each hole data type that contains coded data, that is: Headers, 

Drilling, Geology, Seams, Water Flows, Defects and Point Loads. As Geologists, Cementing, 

Coal Quality and UCS do not have any coded fields, they do not require dictionaries.  

 

3.6 Creating a Dictionary 

In LogCheck, a dictionary is a list of codes and their descriptions. A dictionary can be generated 

in three ways: 

• Creating from scratch. 

• Copying dictionary files from another project. 

• Importing a dictionary from a text file. 

 

These are described in the following sections. The location of dictionaries is described in 

Chapter 11.  

LogCheck also automatically creates a dictionary in the directory called LAS for the LAS files. 

This contains a list of all the variable names and units used in the project’s LAS files. This 

dictionary can be viewed but not modified. In order to create a new dictionary, you need to be in 

Manager mode – see Section 3.2.1 of this chapter for how to set the Manager mode. 

 

3.6.1 Creating a Dictionary from Scratch 

A new dictionary can be created by: 

selecting File > New > Dictionary from 

the LogCheck menu. The prompt to the 

right will then appear. Note that the 

Dictionary menu item only appears on the 

File > New menu if the user is in Manager 

mode. 

 

 

 

 

In this dialog, you need to choose between a default dictionary, or one that is specific to a 

project. A default dictionary should be chosen for codes that will be available for many projects, 

whereas a dictionary specific to a project for codes that will only be used in one project, for 

example a Seam Dictionary.  

Chose between a default 

dictionary, or one 

specific to a project 
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On selecting the Project and Data Type, and then clicking OK, the new current data set in 

LogCheck will be the entire dictionary for the selected data type, that is all categories. However, 

being a new dictionary, there will be nothing in any of the categories. To enter dictionary data 

open each category in turn by selecting File > Open > Dictionary… from the LogCheck menu.  

Be aware, it has been known for users to have a default dictionary and then to accidentally 

create a new project dictionary with nothing in it. They are then mystified as to why their 

dictionary, that is the default dictionary, has “disappeared”. 

3.6.2 Copying Dictionary Files 

A dictionary file can be created by copying the dictionary files Data Type Dictionary.dbf and 

Data Type Dictionary.mdx from another computer or project. Copying dictionaries is the most 

common way to obtain dictionaries.  

The dictionary files can be copied from a fixed disk drive, memory stick or CD using Windows 

Explorer or saving them where they have been sent as email attachments. Project-specific 

dictionary files need to be copied to their corresponding data folder for the project; for example, 

a Geology dictionary is copied to the Geology folder, and is named Geology Dictionary.dbf. 

The file locations for dictionaries are described in detail in Chapter 11 and an example is. 

 C:\LogData\AVOCA\Geology\Geology Dictionary.dbf 
 

Default dictionaries should be copied to the Dictionaries folder in the LogCheck data folder, 

usually C:\LogData\Dictionaries. 

3.6.3 Importing a Dictionary from a Text File 

A dictionary can be created in a project by importing from a text file. This file must have a 

category column containing a six character abbreviation of the category. A list of the 

abbreviations used for any particular version of LogCheck can be obtained from the LogCheck 

distributors. The text file may be in the following formats: 

• Delimited, for example comma (.csv) or tab (.txt) delimited. It does not have to contain 

all the LogCheck dictionary columns but it must contain the Category and Code columns; 

• Fixed Width, this must contain all the LogCheck dictionary columns although columns apart 

from Category and Code may be blank. The columns must have the following starting 

positions and widths: 

 

• Geobank dictionary export (.csv) 

• MineScape (GDB) dictionary dump (.dmp) 

• Minex dictionary (.dic) 

• Vulcan dictionary (.dcl) 
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To import a dictionary from a text file, go to the File > Import > Dictionary menu, where the 

following dialog is displayed: 

Selecting a Dictionary 

Layout option other 

than LogCheck sets 

the default values for 

Data Format and 

Column Delimiter. 

If LogCheck is chosen 

as the Dictionary 

Layout, then the Data 

Format can be either 

Delimited or Fixed 

width, and the 

Column Delimiter can 

be one of comma, 

semi-colon, tab, space, 

or some other 

character. 

 

 

 

 

 

 

 

The difference between the terms copying and importing a dictionary file is that with the former, 

the file is already a LogCheck database file, whereas the latter is in some other format. 
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3.7 Opening a Dictionary in the Editor Form 

To open a dictionary, go to File > Open > Dictionary, where the dialog below is displayed. This 

dialog allows you to either select the default dictionary in C:\Logdata\Dictionaries or a specific 

dictionary for a data type, and for that data type, to select either all categories, or a specific category. 

For each dictionary data type, there 

are a number of categories. For 

example, Headers has categories of 

Hole Type, Survey …, etc, as shown 

in the dialog on the right. 

 

 

 

 

 

 

 

 

 

3.7.1 Selecting All Categories 

If the All Categories option is selected, on clicking the OK button, a list of all the categories in that 

dictionary is displayed, for example: 

Categories 

for Headers 

data type 

Chose between a default 

dictionary, or one 

specific to a project 
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Open All Categories to print a dictionary report or to export it to other software. To print a dictionary, 

from the main menu, go to File > Print, then choose either Data or Report. Exporting dictionary data is 

described in Chapter 9. 

3.7.2 Selecting a Specific Category 

Selecting a specific category from the dictionary allows viewing/editing of the data in that category. In 

this case, one of the three Order options can be selected: 

• Unsorted, 

• Sorted on code or  

• Sorted on description. 

 

The Unsorted option 

displays the entries in the 

order they were added to 

the dictionary. For example, 

if you want LogCheck to 

ensure that seams are in 

stratigraphic order, then you 

first need to enter them into 

LogCheck in that order. 

 

 

 

 

 

3.8 Modifying a Dictionary 

In order to modify a dictionary, you need to be in Manager mode. The Manager option of the 

Settings menu allows you to switch from General User mode to Manager mode. When in 

Manager mode, you can modify a dictionary in the current project or import a dictionary from 

some other source. The figure below shows a lithotype dictionary opened in Manager mode: 
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In User mode, the dictionary is read-only. This is indicated in the Title bar of the LogCheck editor 

and by all the text being grey. If a Sorted option is selected, entries can only be appended to the 

data set – although after each record is completed, it is placed in sorted order in the edit form. 

3.9 Dictionary Structure 

All LogCheck dictionaries have the same twelve column structure. As an example, the following 

diagram shows the first few lines of the Lithotype category of a Geology dictionary: 

 

1. Code: Used by the geologist when entering data; 

2. Desc: The full description that the code represents. This is what will appear for 

the code in reports, and in plots where descriptions are being displayed; 

3. Group: Is used to group certain dictionary entries. It is used in various parts of 

LogCheck, and is discussed in more detail in the following section; 

4. Before: Indicates that when the entry appears in a full 

English description a comma should be 

included before the word. For example (as 

shown on the right), in the Lithological 

Adjectives dictionary there is an N for No in 

the Before column of entries for blebs and 

bands as, in general, the words blebs and 

bands will probably be proceeded by another 

qualifier such as sandy; 

5. After: Indicates that when the entry appears in a full English description a 

comma should be included after the word. For example, in the dictionary 

above there is an N for No in the After column of abundant and altered, 

because generally the words abundant and altered will probably be 

followed by other qualifiers such as fractures. 

 

When there are two qualifiers together, if the value for After for the first  

is different  to the Before value of the second, the N(No) takes 

precedence. 
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6. Pattern: The primary pattern that will be used for plotting (see Appendix C for a 

full list of standard patterns).  

7. Pattern2: The secondary pattern for plotting – if specified, it is combined with the 

primary pattern (see Appendix C for a full list); 

8. Colour: This can contain a number between 1 and 255 which represents an 

AutoCAD colour number (see Appendix E for a full list of AutoCAD 

colours). For example, in the dictionary shown in the following section 

containing a number of lines from the Seam/Horizon category of a Geology 

Dictionary, the WK1 Seam (Warkworth 1) has Colour set to 60. When using 

LogCheck to plot sections this seam will have a colour of 60 which translates 

to a brownish-yellow colour;  

9. Fill: The type of fill that will be used for plotting (see Appendix D for a full 

list of standard fills); 

10. FillColour:  An AutoCAD colour number that will be used for drawing the fill (see 

Appendix E); 

11. BgColour:  An AutoCAD colour number that will be used for colouring the 

background (see Appendix E); 

12. Comments: This is not used by LogCheck. It is provided so that the user can enter 

reminder notes that they may need when doing dictionary housekeeping.  

3.10 The Group Column 

The Group column is used by LogCheck’s audits, summaries and statistical tools – it allows you 

to define your own groups when performing statistical analysis of the data. As well as this, 

LogCheck uses the information in the Group column for generating audits and summaries. For 

most dictionary categories it is not required, however it is required in the following 

circumstances: 

 (a) The Group column of the Lithotype 

dictionary needs COAL against 

anything that is coal and CORE 

LOSS against any core losses, as 

shown to the right. This enables 

LogCheck to calculate items such as 

the amount of coal in a seam and 

the percentage recovery.  
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 (b) In the case of the Seam/Horizon dictionary category as shown below, the Group is 

required and can only have the values HORIZ, SEAM or STRAT. HORIZ being a zero 

thickness unit. SEAM a non-zero thickness unit that is economic and STRAT a non-zero 

thickness unit which is non-economic. 

 

Note that if using the CoalLog version of LogCheck, the Horizon is not stored in the seam 

column, but has its own column and category and as such does not require a group. 

 

(c) In the drilling dictionary, the Bit Type category needs CORED against any bit types that 

produce core rather than chips. This enables LogCheck to know which parts of a hole 

have been cored and which have not. An example is shown below: 
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3.11 Geology Dictionary in CoalLog Version 

In the CoalLog version of LogCheck there is a Lithotype  and Lithology Qualifier category. 

Lithotype is a broader term, for example, all coal has a Lithotype code of CO, and its detailed 

characteristics are specified by its Lithology Qualifier code. Because some Lithology Qualifiers 

only relate to particular Lithotype entries, there is an additional category of Lithotype + 

Qualifier Combination which is used to specify the valid combinations. The patterns and fills 

for the combinations are also defined in this category. The Select Required Dictionary dialog 

with the three categories is displayed below. 

 

The Lithotype + Qualifier Combination dictionary is shown below.  
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Chapter 4  
Project Details 

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Enter the project details data. 

� Specify the LAS file directory for a project. 

� Specify the datum and format of survey coordinates for a project. 

� Specify the project limits. 

� Specify the depth units for a project. 

� Specify the UCS calculation parameters for a project. 
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4.1 Project Details Data 

Once a project is created the Project Details for the project becomes the current data set. The 

project data consists of the following entities: 

• Project title. 

• LAS (geophysical logs) File Directory. 

• Geodetic Datum, 

• Survey Coordinates Format, 

• Depth Units, 

• Project Limits, 

• UCS (Uniaxial Compressive Strength) formula for the project. 

 

 

An example of the Project Details for an example project named Avoca is shown below:  

 

These fields are described in the following sections (note that only the default values are shown 

above). 
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4.1.1 Project Title 

This is the title for printing on reports, plots etc. The Project Title can contain blanks and can be 

of any length. The Project Title is provided because the Project Name used by LogCheck can 

only be a maximum of eight characters and can not contain blanks. This field enables the user to 

provide a more meaningful title than that provided by the Project Name. 

4.1.2 LAS File Directory 

LogCheck requires all downhole geophysical logs to be in LAS V1.2 or LAS V2.0 format. The 

LAS format was developed by the Canadian Well Logging Society. More information regarding 

the LAS format can be found on its website at www.cwls.org/las_info.php. 

LogCheck enforces a strict discipline on the location and naming of data files. The only 

exception to this is the LAS data which may reside anywhere on the user’s computer or their 

network. As LAS data tends to occupy large amounts of disk space and may be accessed by a 

number of applications, the user is able to specify a separate location for it so as to reduce the 

need for multiple copies of the data, copying the data and/or holding it permanently on their 

hard drive.  

When LogCheck is looking for LAS data it will search the directory specified in the Project 

Details. It will also search all lower directories off this directory. If this field is blank, LogCheck 

will instead search the LAS directory under the project folder and again all lower directories off 

this. The only restriction is that the chain of lower directories and the filename must not contain 

more than 36 characters. Be aware though, that the directories should not contain more than one 

set of readings for any particular geophysical variable at a particular reading interval, over the 

same depth interval of a particular hole. 

4.1.3 Geodetic Datum 

The display of coordinate data in LogCheck can be based on either: 

• Australian Geodetic Datum (AGD84), or 

• Geocentric Datum of Australia (GDA94) 

 

The Australian Map Grid 1984 (AMG84) uses the AGD84 datum for its geographical 

coordinates, whereas Map Grid of Australia (MGA) used the GDA94 datum for its geographical 

coordinates. 

As coordinate data is entered and saved in LogCheck, it is stored in both formats. These options 

determine in which datum coordinates are displayed. LogCheck uses GCalc software from the 

Queensland Department of Natural Resources and Mines, to convert between datums. 
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4.1.4 Format for Survey Coordinates  

The format for the display of survey coordinates in LogCheck is specified with one of the 

following options: 

• Grid, 

• Longitude/Latitude as decimal degrees, or 

• Longitude/Latitude as degrees/minutes/seconds. 

 

Historically, most coal exploration data in Australia was recorded in AMG’s and most 

petroleum exploration data in Longitude/Latitude with decimal degrees. At the start of 2005, the 

New South Wales Department of Mineral Resources insisted that coordinate data needed to be 

referenced to the new MGA. Queensland, as of the start of 2013, still has not enforced a 

changeover.  

The Survey Coordinates Format option changes what system is used when the coordinates are 

entered, displayed, printed and exported. For example, often in coal bed methane work some of 

the historical data will come from coal exploration and some from petroleum exploration. When 

entering old petroleum data in Longitude/Latitude with decimal degrees change the option to 

Longitude/Latitude (decimal degrees). All the current data in the system for the project will then 

be displayed in Longitude/Latitude though it will still be stored in AMG’s/MGA’s.  

The latitude and longitude of a survey point will change depending on which geodetic datum 

was used for calculating it. Therefore when entering latitudes and longitudes, firstly determine 

which geodetic datum was used and that the appropriate one is selected in the Project Details. 

When changing coordinate systems, LogCheck does not recalculate the actual stored data, just 

what is displayed on the screen and in reports, as there is a small rounding error each time the 

coordinates are recalculated. If the recalculated coordinates overwrote the previous coordinates, 

then after changing coordinate systems a number of times then the rounding errors could 

accumulate and finally become significant. It is suggested that when working outside Australia, 

that AMG’s are used. The actual grid is only relevant if the coordinates need to be transformed 

to another system. If this is necessary outside Australia contact the LogCheck distributors so that 

the software can be appropriately modified. 

 

4.1.5 Depth Units 

Depth Units specifies the unit of measurement that is used for editing hole data. Often historical 

data will be in feet and inches or decimal feet. By selecting the appropriate Depth Units option 

the format used for entering the data can be modified. Upon entering, the data is stored in 

metres and all reporting, plotting and exporting of the data is in metres. This option can be 

changed at any time so that the Hole Data stored on the machine can be edited/displayed in the 

required format. 
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4.1.6 Project Limits 

Project Limits are a rectangular set of limits, and a minimum and maximum elevation for hole 

collars. The horizontal limits are set by specifying a minimum and maximum Easting/Northing 

coordinate pair.  Survey coordinates are validated against the project limits. This is performed 

whenever coordinates are entered at the keyboard or imported from file.  If the AGD84 datum is 

selected, then AMG Easting/Northing coordinates are used for the project limits. If the GDA94 

datum is selected, then MGA Easting/Northing coordinates are used for the project limits. 

Where the user’s Header format does not contain a field for recording the Zone then the 

maximum Zone is automatically set to the same as the minimum zone. This zone will be applied 

to all coordinates when transforming the coordinates to Longitude/Latitude. 

 

4.1.7 UCS Calculation Parameters 

UCS (Uniaxial Compressive Strength) can be estimated from Sonic Transit Time or Velocity 

data. It is common practice within the Australian coal industry to determine a relationship 

between the UCS and sonic data for each project based on lab results of UCS and Sonic values 

for a number of samples from preliminary holes.  

Once a relationship has been established it can be used to generate UCS values for hole zones 

where no laboratory UCS tests have been performed but downhole sonic values have been 

recorded. More information about this procedure can be found in “Geotechnical applications 

and interpretations of downhole geophysical logs” by G.H. McNally published by Australian 

Coal Industry Research Laboratories, Sydney. If required, LogCheck will calculate these UCS 

values when opening LAS data containing sonic data. 
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Chapter 5  
 Hole and Interval Selection  

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Open holes for editing. 

� Create and edit a group of holes known as a hole set. 

� Create and edit a set of hole data intervals. 

 

 

 

5.1  Introduction  

This chapter describes how to select drill holes. Once open, the drill holes can be viewed, 

edited, revalidated, plotted, exported and/or reports generated. You can select a single hole, all 

holes, or a group of holes, known as a hole set. For the selected hole or holes, you can also 

select a predefined interval, known as an interval definition. This is usually used for plotting just 

part of a drill hole, for example, from the roof of a specified seam to the floor of a specified 

seam. 

Holes in a hole set can be selected from a list, or by specifying a section, such as north-south or 

oblique section, or by creating a query or by importing a list from a text file. 
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5.2 Opening Hole Data 

To open the data for a drill 

hole, go to the File menu, 

select Open, then select Hole 

Data (as shown on the right). 

Alternatively, the hot key is 

Ctrl+O. This only applies to 

existing holes; to create a new 

hole use File > New > Hole 

Data (see Chapter 2). 

 

 

 

 

This brings up the following dialog: 

 

The options on this screen are: 

• Project, 

• Data Type, 

• Hole Selection, 

• Interval Selection. 

 

Note that the interval selection is not available for header data as all its data applies to the entire 

hole. If you select only part of the hole, you can view, but not modify it.  These options are 

described in the following sections. Click the OK button when you are done. 
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5.2.1 Project 

Selecting from this drop-down list allows you to choose the project whose holes you are 

opening. The list will only contain projects that have existing hole data. 

5.2.2 Data Type 

Selecting from this drop-down list allows you to choose the data type of the holes that you are opening. 

This list only contains the data type for which there is hole data in the currently selected project. 

5.2.3 Hole Selection 

There are three options when selecting holes: 

• All holes: All holes for the project are selected. 

• Hole Set: Only those holes in a specified hole set are available (see following section). 

• Single Hole: Only the hole specified is selected. Choose the required hole from the 

drop-down list. This list only contains the holes within the current 

project that have the currently selected data type. 

 

To edit data for a hole, the Single Hole option must be selected. If multiple holes are opened, 

using the All Holes or Hole Set options, you can export, print and/or plot data, however editing 

is limited to the Find or Find and Replace functions. After selecting multiple holes, the screen 

will show the project, data type and a list of the holes that are currently open, as shown below: 

 

5.2.4 Interval Selection 

The interval selection option allows you to specify which part of the hole(s) you will be working 

with. The available options are: 

• Entire hole: Entire hole available for editing. 

• Specify top and bottom depths: Specify a top and bottom depth in metres. 

• Use interval definition: Select an interval – see the Section 5.4 in this chapter for 

instructions on how to create an interval definition. 

 

Note that if selecting less than the entire hole then the data opens in read-only mode. Generally, 

opening less than the entire hole is used for plotting or reporting. 
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5.3  Creating/Editing a Hole Set Definition 

A Hole Set Definition is a group of holes that can be operated on simultaneously, for example: 

• Validating a group of holes, 

• Plotting a group of holes, 

• Reporting for a group of holes, or 

• Exporting data for a group of holes to other systems. 

 

To create a new Hole Set 

Definition, go to File > 

New > Definition, then 

select Hole Set: 

In addition, a Hole Set 

Definition can also be 

created by importing a list 

of holes in a text file. 

 

 

 

This displays the dialog to enter the name for 

the Hole Set Definition, as shown on the 

right: 

Enter a relevant name (in this example, 

MAIN_NS), then click OK.  

To open an existing Hole Set Definition, go 

to File > Open > Hole Set definition, and 

select the required Hole Set. 

The Hole Set 

Definition dialog is 

then displayed, as 

shown on the right. 

This dialog allows 

you to select holes for 

a hole set definition 

by one of three ways: 

• Select by picking 

from list; 

• Select by section; 

• Select using a 

query. 
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5.3.1 Select by Picking from List 

In the previous diagram, the list on the left displays all holes in the project for which data exists 

for at least one data type. Select from the list on the left, then click the Add to Selection button. 

Multiple selections can be made by using the Ctrl or Shift keys with the mouse. The example on 

the previous page shows that holes AVC030C, AVC031C and AVC032 have so far been 

included in the hole set definition set MAIN_NS. To remove holes from the list, select them and 

then click the Remove From Selection button. 

5.3.2 Select by Section 

The figure on the right is part 

of the Hole Set Definition 

form that allows you to create 

a hole set by selecting drill 

holes that are located along a 

section. Select by section type: 

• East-West,  

• North-South,  

• Oblique or  

• Section between specified 

holes.  

 

The Section Corridor 

Tolerance allows you to set 

the width of the corridor for 

including holes. Clearly, 

Select by Section can only 

select holes whose coordinates 

have been entered in the 

header data. 

 

5.3.3 Select using a Query 

The figure below is part of the Hole Set Definition form that allows you to create a hole set by 

using a query. The query is in DBL, which is the dBase query language (see Appendix A).  

In this example, 

Seam is the 

variable name at 

the heading of the 

Seam/horizon 

column when 

editing Geology 

data. This query will include all holes where seam “WK2” has been logged. Note that the 

“WK2” requires the double quotes.  

When you have finished creating your hole set definition, go to the File menu, then select Save. 

Note: as the actual hole set definition is the current LogCheck “data”, closing it by selecting the 

X button in the top right corner closes LogCheck not just the “data”. 
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5.3.4 Importing a Hole Set 

A Hole Set Definition can also be created by 

importing a list of holes contained in a text file. For 

example, Notepad can be used to create a list of hole 

names, as shown on the right:  

 

 

(a) In LogCheck, go to the File > Import >   (b) Next, accept the defaults from the  

     Hole Set List menu:          Import Data dialog: 

 

 

(c) Select the file containing the list of holes:   (d) Next, provide a name:  

 

 

 

 

 

 

 

 

The resulting holes are displayed in LogCheck, as shown by the 

fragment from the Hole Definition screen on the right: 



CHAPTER 5. HOLE SETS & INTERVAL DEFINITIONS 

 LogCheck Manual 53 

5.4  Creating/Editing Interval Definitions 

An Interval Definition allows you to maintain downhole intervals, based on specific criteria for 

the top and bottom of the interval. This can be used in the Open Hole dialog to specify which 

part of a hole or holes to open for viewing, revalidating, plotting, exporting and/or reporting. 

5.4.1 Creating a New Interval Definition 

To create a new Interval 

Definition, go to File > New > 

Definition, then select Interval 

Definition. 

This displays the dialog to 

enter the name for the Interval 

Definition: 

 

 

Enter a relevant name (in this example, WK23SEAM), then click OK. Next, the Interval 

Definition dialog is displayed:  

 

As with the Query 

option in the Hole 

Set Definition, the 

response to the 

Selected Units 

prompt for the 

interval Top and 

Bottom is in DBL 

(see Appendix A). 
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5.4.2 Open an Existing Interval Definition 

To open an existing Interval 

Definition, go to File > Open > 

Definition, then select Interval 

Definition. This brings up the dialog 

as shown on the right:  

 

Click the OK button to display the 

Interval Definition form (shown 

below). 

Interval definitions can be specified that display as a single interval, or as multiple intervals that 

do not display all the intervening intervals between the units in the LogCheck editor. Examples 

of these are discussed in the following sections. 

5.4.2.1 Example 1:  Single Interval for One or More Units 

An interval definition based on the geology data that runs from 2.0m above the top of the WK2 

seam to 2.0m below the base of the WK3 seam that will display as a single interval in the 

LogCheck editor is shown below: 
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The result of opening up hole AVC035 with the WK23SEAM interval definition in the 

LogCheck hole editor is shown below on the left. If the hole is then plotted (File > Plot), the 

results are shown on the right. This example also illustrates the effect of selecting the “Single 

interval from the first top to the last bottom” option from the Multiple Interval choices in the 

interval definition.  

 

 

 

 

 

 

 

 

 

 

 

 

The range selected by this interval definition is displayed as a single interval in the LogCheck 

editor even though the intervening interval between the WK2 and WK3 seams is longer than the 

2.0m above the WK2 seam and below the WK3 seam. 

Note that a blank row coloured dark grey is used to indicate that only part of the hole has been 

opened. Although the total logged depth of the hole is 314.0m, the editor only displays down to 

the 2.0 m below the base of the WK3 seam that was specified in the interval definition. 

The data type used for the selection criteria does not have to be the same as the data type that is 

being opened. For example, the above interval definition could be used to open the LAS data for 

all depths from 2.0m above the top of the WK2 seam to 2.0m below the base of the WK3 seam. 

As a variation on this example, if “WK2” and “WK3” is replaced with “WK”, this would define 

an interval running from 2.0m above the first seam starting with “WK” to 2.0m below the last 

seam starting with a “WK”. 

Because the selection criteria are applied with the dBASE DBL query language, specifying 

“WK  ”, where there is a blank after the “K”, then it would select from 2.0m above the first 

seam named precisely “WK” to 2.0m below the seam named precisely “WK”. In this case, the 

trailing blank enforces a strict match with the characters, rather than matching any seam that 

started with “WK”. 

WK3 

WK2 
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5.4.2.2 Example 2: Seam Roof Plus Adjacent Bolting Horizon Definition 

If a bolting horizon is required to be included in the interval, for example 0.5m of the unit that is 

directly above the unit that constitutes the roof of the seam, select the “top of unit directly above 

selected units” option for the top interval. In this example, the Interval Top Definition is set at 0.5 

m above the top of the unit that overlies the WK2 seam, and the Interval Bottom Definition is set at 

0.0 m above the top of the WK2 seam – that is, the top of the WK2 seam. 

 

The result of opening up hole AVC031C with the WK2ROOF interval definition in the 

LogCheck hole editor is shown below. Note that a blank row coloured dark grey is used to mark 

the beginning of the selected interval.  

Top interval: 0.5m 

above the unit (MS) 

overlying WK2 seam 

Bottom interval: 

0.0m above top of 

WK2 seam. 

The interval displayed in the LogCheck 

editor is indicated by the dashed (red) line 

on the plot. 
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5.4.2.3 Example 3: selecting multiple intervals in a single hole  

This example illustrates the effect of selecting the “multiple intervals from each top to the first 

bottom below that top” option from the Multiple Interval choices in the interval definition. The 

effect is to select potentially non-contiguous sequences and display them at the same time. 

 

 
 

In this example, the Interval Top Definition is set to 1.0 m above each seam that occurs in the 

hole. The Interval Bottom Definition is set to 1.0 m below each seam that occurs in the hole. 

The end result is to select all seams that occur in the hole, but only the seam itself and 1.0 m of 

the roof and 1.0 m below the floor. 

 

 

The restriction: SEAM <> " "  gives every single seam and adding CALCTHICK > 0 excludes 

horizons. Note that there is a single blank between the quotes for the seam. 

 

The “multiple intervals” option has been selected – the effect of this is shown in a sample plot 

on the following page. 
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The result of opening up hole AVC031C with the SEAM interval definition in the LogCheck 

hole editor is shown below. Note that a blank row coloured dark grey is used to separate the 

selected intervals – in this case each seam and 1.0 m above it and 1.0 m below it. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The results of plotting this data are shown below. Note the effect of selecting “multiple 

intervals” – exactly 1.0m above and below each seam, and the seam itself is selected. 
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5.4.2.4 Example 4: a single interval from the first top to the first bottom below it  

This example illustrates the effect of selecting the “a single interval from the first top to the first 

bottom below it” option from the Multiple Interval choices in the interval definition. 

 

 

 

The resulting plot is displayed below. 
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Chapter 6  
 Data Formats 

 

 

 

By the end of this chapter you will be able to: 

 

� Understand the types of LogCheck data formats. 

� Understand the format of hole header data. 

� Understand the format of geologists, casing and cementing data. 

� Understand the format of drilling data. 

� Understand the format of geology data. 

� Understand the format of defect data. 

� Understand the format of LAS data. 

� Understand the format of point load test data. 

� . 
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6.1 Introduction  

The purpose of this chapter is to describe how to open holes for editing, methods of selecting holes 

and the data format for each of the types of hole data that is available in LogCheck. Most of the 

formats in this chapter conform to the CoalLog 4 format – however the data formats for a given 

project may vary from what is described here. Data formats include: 

• Headers, 

• Geologists, 

• Casing, 

• Cementing, 

• Drilling, 

• Geology, 

• Water Flows, 

• LAS, 

• Defects, 

• Point Loads, 

• Basic Coal Quality, 

• UCS Laboratory Measurements. 

 

Viewing LogCheck data can be done in two modes: 

• Grid layout, or 

• Form layout. 

 

To switch between the two, go to the View menu and select the required layout. 

6.2 Header Data 

Header data consists of data for which there is usually a single value for the entire hole.  For 

example, data that is recorded for a hole includes the hole name, survey data (easting, northing 

and elevation), total depth. An example in form view is shown below:  

 

The First, Previous, Next 

and Last buttons are 

disabled, because only 

one hole was selected. 
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When opening header data if more than one hole is selected, the data is displayed by default in 

Grid layout as shown below: 

 

 

You can switch to Form layout from the View menu, in which case, the First, Previous, Next 

and Last buttons are available to navigate between the holes. The variables will differ for 

different versions of LogCheck, but will usually contain the following: 

• SiteId:  The site identification code. 

• HT: Hole type – fully cored or open, etc. 

• DS:  Data Status – raw, final, etc. 

• UTMZone: Map Zone. 

• Easting: The easting coordinate. 

• Northing: The northing coordinate. 

• Elevation: The elevation of the hole collar. 

• GeoOrg: Geological logging organisation 

• TotDep: Total depth of the hole. 

• Inc: Hole inclination 

• Azi: Azimuth of the hole. 

• HS: Hole Status. 

• GphLog: Geophysical logging company. 

• L1 – L10: Flags to indicate which geophysical logs were recorded on the hole. 

 

6.3 Geologist Data 

For each hole, the geologist data can be recorded. The fields are Base Depth and Logging 

Geologist. An example of the Geologist data for a hole in grid format is shown below: 
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6.4 Casing Data 

For each hole, the casing data can be recorded. The fields are Base Depth, Casing Type, Casing 

Size, Casing Retrieved and Comments. An example of the Casing data for a hole in grid format 

is shown below: 

 

6.5 Cementing Data 

For each hole, the cementing data can be recorded. The compulsory fields are From Depth, To 

Depth, Date and Actual Volume (m
3
). An example of the drilling data for a hole in grid format 

is shown below: 
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6.6 Drilling Data 

For each hole, the drilling data can be recorded. The compulsory fields are Base Depth, Bit 

Type and where Bit Type includes cored data, the Core Size. An example of the drilling data for 

a hole in grid format is shown below: 

 

 

On switching to form layout, the drilling data appears as shown below: 
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The entries for drilling data include: 

• Depth:  The depth to the base of the core. The top of an interval is assumed to be 

the base depth of the previous interval. 

• RunNo: Run number. 

• RecThk: Recovered thickness. 

• ThkDiff:  The recovered thickness. 

• CumThk:  The cumulative recovered thickness. 

• Date: The date of the drilling. 

• DrC: The drilling contractor. 

• RigNo: The rig number. 

• RT: The rig type. 

• Driller: The name of the driller. 

• BT: The bit type. 

• DF: Drilling fluid used. 

• DrSz: Drill size name. 

• CoSz: Core size. 

• HSz: Hole size. 

• Reamed: Whether or not the hole has been reamed. 

 

 

For cored intervals, the difference between the base depth and the top depth must be less than 

the maximum core run length, which is set in the Settings > Validations menu, which only 

appears if you are in Manager Mode, as shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Set value for maximum 

core run length: 
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6.7 Geology Data 

An example of Geology data in grid format is shown below: 

 

 

The same hole in form view is shown below: 
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Fields that will be in the Geology data for every user include: 

 

• Calculated Thickness:  The interval base depth minus the base depth of the previous 

interval. This is a readonly field calculated on the fly by the 

program as the user enters interval base depth values. 

• Interval Base Depth:  The depth of the base of the lithological unit. The interval top is 

assumed to be the base depth of the previous unit. Interval base 

depth must be greater than or equal to the base depth of the 

previous unit. If the base depth is equal to that of the previous 

unit it is assumed that the unit is an horizon, in which case, it 

must have a horizon entered in the Seam/Strat column and if the 

user is using Vulcan a lithology, usually NL for Not Logged, in 

the Lithotype/Rock Type column. It cannot have values in any 

of the other columns apart from the Comments column. A 

Seam/Strat code is denoted as being an Horizon by having a 

value of HORIZ in the its Group column in the dictionary. 

• Sample Number:  This should appear on at least the first record within each 

lithological unit that is part of a sample. Despite its name it can 

contain both numbers and letters. 

• Horizon/Seam Name:  This should appear on at least the first record within each 

lithological unit which the unit wishes to denote as a 

Stratigraphic unit or Seam. 

• % Lithotype:  Where a lithological unit consists of more than one 

lithotype/rock type the user must specify what percentage of the 

lithological unit consists of this lithotype/rock type. 

• Lithotype/Rock Type:  The Lithotype/Rock Type of a portion of a lithological unit 

• Comments:  The comment field appears on the far right hand side of the 

table. It only shows the first line of the comment. If the user 

wants to see the subsequent lines and/or edit the comment they 

need to hit the spanner button that appears on the right-hand 

side of the field when they click on it. There is no limit on the 

size of the comment for each record, however, be aware that on 

exporting the data to other systems most have a limit on the size 

of their comments. 

Each lithological unit can include multiple lines including multiple lithologies. It must contain 

an interval base depth on the first line in the unit and then subsequent lines must have the 

interval base depth as blank. Each new lithology within the unit is included by a code in the 

Lithotype/Rock Type column. The user can extend the description of each rock type over a 

number of lines but must leave the rock type blank on these subsequent lines. 

 

Note that LogCheck only checks that: 

• depths increase down the hole,  

• lithotype percentages add up to 100% and  

• that horizon lines only contain horizons and no other data  

when the user attempts to save their data as these restrictions may not be temporarily satisfied 

while the user is editing their data. 
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6.8 LAS Data 

The LAS file records geophysical data obtained from logging a hole, such as gamma, density 

and calliper recordings. The format of a LAS file is available from the Canadian Well Logging 

Society and can be found on its website at:  

 www.cwls.org/las_info.php 

LAS data is stored in an 

ASCII file (it can be opened 

in Notepad). LAS data can 

also be opened in LogCheck – 

go to File > Open > Hole 

Data, then select “LAS” from 

the Data Type list. When 

opened in LogCheck, LAS 

data is read-only. An example 

of LAS data is shown below: 

 

6.9 Defect Data 

In LogCheck, there are two 

parts to defect data – on the left 

hand side, from the Depth – 

Desc columns, are rock mass 

unit (RMU) details. A single 

RMU has uniform geotechnical 

characteristics. On the right 

hand side is a description of 

each of the defects. For 

example, in the following hole, 

from 40.35 – 51.96 is a RMU, 

with a defect logged at 41.83 – 

BP (Bedding Planes). It is 

important to note that the Depth value is the top of the RMU. The entries for defect data include: 

• Depth:  The depth to the top of the RMU. 

• RT: Rock mass unit type, for example, SS – sandstone. 

• ST:  Estimated strength, for example, MS – moderate strength rock. 

• We: Weathering, for example, F – fresh. 

• P: Plasticity, for example, P – puggy. 

• Sl: Slaking potential, for example, 4 – moderate slaking. 

• Desc: Description of the RMU. 

• Defect: The base depth of the defect. 

• DT: A defect type within the RMU, for example, BP – bedding planes. 

• Sh: Surface shape, for example, P – planar. 

• Ro: Surface roughness, for example, K – slickensided. 

• DC: Defect continuity, for example, 1 – one end terminates. 

• An: Average angle to core, in degrees. 

• Width: Defect aperture width (in mm). 
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6.10 Point Load Test Data 

In a point load test, a stick of core is subject to compressive forces in both axial and diametral 

directions, until the core fails. The force measured is the force in kN at which the core fails. 

Results are standardized to a 50 mm diameter core size.  An established testing procedure 

involves: 

(a) An initial diametral test, where pressure is applied along the diameter of the core, until 

it breaks into two sticks of core. 

(b) A diametral test is applied to each of the two sticks derived from (a).  

(c) This usually results in four pieces of core on which axial tests are done. In an axial test, 

pressure is applied along the longitudinal axis of the core  

Examples of valid diametral failures are as shown below: 

 

 

 

 

 

Examples of valid axial failures are as shown below: 

 

 

 

 

 

 

Examples of invalid failures are shown below (diametral on the left, and axial on the right): 
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For Point Load test results to be included in the calculation of Point Load Indices, they must be: 

(a) A valid test, 

(b) If it is a diametral test, the core length must be greater than the diameter, or 

(c) If it is an axial test, the core length must be less than or equal to the diameter and 

greater than 0.3 times the diameter. 

In LogCheck, an example of point load test data is shown below: 

 

 

For example, in the figure above, for the depth of 182.13, Test No. 1 is the initial diametral test, 

Test Nos. 2 and 3 are the tests on the two sticks of core derived from Test No. 1, and Test Nos. 

4, 5, 6 and 7 are the results of the axial tests on the each of the two sticks of core derived from 

Test Nos. 2 and 3. 

In this diagram, the columns are: 

• Depth:  The depth to the base of the sample. 

• Thickness:  The original length of the sample. 

• SampType: This can be either wet (W) or dry (D). 

• TestNo: This is a unique number within a sample to uniquely identify a particular 

test within LogCheck. 

• TestType: Refers to the direction that the pressure was applied in; this can be either 

diametral (D) or axial (A). 

• Length: Always the length down the core, regardless of the TestType. 

• Diameter: The diameter of the core. 

• Load: The force in kN at which the core failed. 

• Valid: Refers to whether the failure was a valid one or not (see above diagram for 

examples of invalid failures. 
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6.11 Basic Coal Quality Data 

Normally coal quality data is entered via importing a CSV file supplied by the laboratory. If the 

CSV file does not contain fixed carbon values, the import routine calculates the fixed carbon by 

subtracting the inherent moisture, ash and volatile matter percentages from 100%. 

If only one of specific energy or calorific values is supplied, the import routine calculates the 

other from the supplied value. You can’t enter coal quality sample numbers unless those sample 

numbers also exist within the geology data for that hole.  

 

 

6.12 Water Flow Data 

Water flow is flow out of 

the hole from particular 

depths – you can use the 

dictionary to specify the 

measurements. 
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Chapter 7  
The LogCheck Editor 

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Navigate the LogCheck editor form. 

� Modify hole data in the hole edit form. 

� Append, copy and delete rows in the hole edit form 

� Find and replace logging codes. 

� Modify options in the Settings menu 

� Validate drill hole data against a dictionary. 

� Import hole data. 

 

 

7.1 Introduction 

The LogCheck editor is used for viewing and modifying dictionaries and hole data, and for 

viewing summaries and audits. Dictionaries can only be viewed; if you need to update a 

dictionary, you need to set Manager status (see Chapter 3). Hole data can generally be modified, 

however if the file properties are set to read-only, it can only be viewed (see following section 

for setting the read-only property).  

Summaries and audits are all read-only. If the data being viewed is read-only, it is shown in 

grey rather than black. In addition, even when you can modify data, there may be calculated 

fields such as calculated thickness that cannot be modified, which are shown in grey. 
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7.1.1 Setting the Read-Only Property 

Setting the read-only 

property can be done for a 

folder, and all of its 

contents or applied to a 

single file. 

To set or unset the read-

only property, requires 

the following steps:  

1. Open up My 

Computer or 

Windows Explorer, 

and navigate to the 

folder where the 

project data is 

stored.  

2. Right-click the 

required folder and  

select the Properties 

item from the 

menu, as shown on 

the right: 

 

 

3. The Properties dialog is shown in the figure below:  

 

 

 

 

 

 

 

 

4. To set the read-only property, click the 

Read-only checkbox so that it is checked 

and click the OK button. 

5. To unset the read-only property, clear the 

check from the box, and click the OK 

button. 
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7.2 The Editor Form 

After selecting the data (for example, hole data or a dictionary) to be edited, the data is displayed in 

LogCheck’s data editor, which can display the data in either Grid Layout, or Form Layout. The 

respective items in the View menu allow you to switch between them, or the Shift+F8 function key 

combination will also toggle between the two views.  

Opening hole data is described in Chapter 5; opening a dictionary is described in Chapter 4. An 

example of Grid Layout is shown below: 

 
 

This form can be scrolled horizontally and vertically. Each row represents a logged drill-hole 

entry and each column represents a variable. The menus that are available along the top of the 

form are: Edit, View, Tools, Settings and Help. The View menu allows you to choose Grid 

View (as shown above) or Form View (as described later in this chapter). 

7.2.1 Navigating the Edit Window 

For existing hole data you can move around the Edit Window by using the following keys: 

• Tab key: Moves to the next column on the current row; 

• Shift Tab key Moves to the previous column; 

• PgDn key Moves down a page at a time; 

• PgUp key: Moves up a page at a time; 

• Ctrl+PgUp: Moves to top of form; 

• Ctrl+PgDn: Moves to bottom of form; 

• Mouse wheel: Scrolls up or down the log; 

• Scroll bars: Drag the vertical or horizontal scrollbars with the mouse; 

• Arrow keys: The Left, Right, Up and Down arrow keys move one item in the 

selected direction. 

• F2: Enables editing of current field; 

• End: Move to end of current field; 

• Home: Move to beginning of current field. 

 

The abbreviation of the current column 
(LQ) is shown in the status line. 
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Note that there is no explicit “Close hole” command – opening another hole automatically 

closes the previously open hole. 

An example of the geology data for a hole in Form Layout is shown below: 

 

In Form Layout (above), all the data for a single row is shown, with a full description of each 

dictionary category. 

Clicking the Next button moves to the next record in the log. Similarly with the Previous, First 

and Last buttons. To enter Remarks, double-click the field to bring up a full-screen editor – 

when entry of Remarks is complete, click the lower Close button. The advantages of this layout 

are that: 

  1. You don’t need to tab across to fields on the right, as in Grid View; 

  2. The full descriptions of fields are shown alongside the values. 
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7.2.2 Display/Hide Fields 

The Display/Hide Fields option of the View menu allows you to select the columns to be 

displayed in the Editor. Tick a column to display it, or untick it to hide it. The Tick All button 

selects all columns for display; the Tick None button de-selects all columns. 

 

 

Since the SampleNumb, Seam and Ply are usually only filled in for coal seams, you can turn 

these off when not in a coal seam, so more of the fields on the right are visible. 

 

 

7.2.3 The Restore Previous Field Display 

The Restore Previous Fields option of the View menu allows you to restore the previously 

selected columns. You can press Shift+F3 to turn these on and off. For example, as you log in 

and out of coal seams. 

This is useful when moving between coal and non-coal lithologies. This will be greyed out if 

you haven’t made any changes in the field display.  
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7.2.4 Modifying Data in the LogCheck Editor 

When entering data into cells in the LogCheck editor, you can either: 

• Type the data in using the keyboard. 

• Use the dictionary/keypad that is displayed on the side of the screen. This is useful when 

using tablets which only have a keyboard that pops up on the screen 

 

When the dictionary is displayed, it changes according to the type of data in the current cell. To 

display the dictionary, go to the View menu, then select the Display Keypad/dictionary option. 

When entering depths, if you enter a value less than 1.0, then LogCheck retrieves the units value 

from the previous line; this makes it faster to enter data by reducing the amount of typing. For 

example, for a depth of 170.80, if the previous depth was 170.25, then you only need type in .80 – 

LogCheck carries the 170 down from above. For numeric fields, such as depth, even though a 

numeric keypad may be displayed, it is often easier to use the keyboard.  Also, when you are familiar 

with the codes in the dictionary, these can be typed into a cell directly. 

 

7.2.5 Display Keypad/Dictionary Menu 

For alphanumeric fields that are dictionary lookup fields, the possible dictionary values for the 

field are displayed. If all the dictionary values for the field do not fit on the screen (for example, 

Lithology), the most recently used values are shown at the top of the list; the remaining values 

can be accessed by scrolling further down the list.  

The Recently Used list is only displayed if the whole list runs on to another page. Only the items you 

have entered will appear on your computer – it will not include those entries used if the hole was 

edited on another computer (the Recently Used list is kept in the project dictionary). 

An example of a the Geology dictionary keypad and its Recently Used list is shown below: 

 

 

 

 

 

 

 

 

 

 

 

The brace indicates the 

Recently Used list – 

the remaining entries 

of the full list are still 

accessible. 
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The size of the recently used list 

can be set in the Options by 

selecting Settings > Options and 

the Editing tab, as shown: 

You can specify which side of the 

screen the dictionary is displayed, 

as shown on the right: 

If using a tablet, left-handed users 

prefer the menu on the left, and 

right-handed users on the right, so 

that their arm does not cover the 

data. 

 

The display of the keypad/dictionary in the hole 

editor  can be toggled on or off from the View 

menu and clicking the Display 

Keypad/Dictionary menu item, or pressing the 

F8 shortcut key, as shown on the right: 

 

 

The dictionary contains all the valid entries for a column. The LogCheck Editor with the 

dictionary/keypad displayed is shown below: 

 

 

 

 

 

 

 

 

1. The current cell is in the Depth 

column – the numeric keypad is 

active, as this is the only valid form 

of input. Clicking the Tab button 

moves to the next field (SampNumb). 

2. The current cell is in the 

SampNumb column – the numeric 

and alpha keypads are active, to allow 

for alphanumeric input. 

3. The current cell is in the Seam 

column – now the dictionary is 

displayed, with the current entry 

highlighted. 
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7.2.6 Multi-Line Comments 

The Comments field on the far right of the Hole Edit 

form allows you to add multi-line comments for a unit. 

When you first enter the field, it shows a spanner in 

the right-hand side, as shown on the right. 

You can either type a single-line comment, or click the 

spanner icon, and a multi-line edit box appears. 

 

 

 

In the multi-line edit box, you can add further 

comments, as shown on the right.  

 

 

 

 

 

 

 

To terminate the input, click the spanner again, and the 

first line of the comment is displayed, as shown 

below: 

 

 

 

 

 

You can force a blank line by putting a space in the first line, then your comments will start on 

the second line. Note that if you just type the Enter key without first putting in a space, dBase 

will remove the blank line. This allows the Comments field to appear in a new line in the 

reports. 
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7.3 The Edit Menu 

 

The Edit menu allows you to insert, 

append, copy, delete and undelete rows. It 

also has options to clear or copy a field, 

and find/replace items. 

The Edit menu appears as shown on the 

right: 

 

 

 

 

 

7.3.1 Inserting Rows Before the Current Row 

To insert new row(s) before the current row in a log, select Edit > Insert Before; the options are 

as shown below: 

 

 

 

 

 

 

When a new row is inserted, it copies data from the columns above. The user can control which 

columns are copied by going to the Settings menu, then selecting Carry Fields (see following 

section). The options are: 

• Single Row:  Inserts a single row, with no further dialog. 

• Multiple Rows:  Inserts multiple rows. 

• Copy of Current Unit: Inserts an identical copy of the current unit, including the depth. 

• Rows from another hole: Inserts the specified rows from another hole 
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The figure below on the left shows the Multiple Rows dialog, which requests the number of new 

rows to insert. The figure on the right shows the insert operation after it has completed. The new 

rows are inserted above the current row, and the specified fields are copied from the row above. 

 

 

 

 

 

 

 

 

 

 

The Carry Fields option of the Settings Menu allows you to choose which fields are copied from 

the previous row, when adding or inserting rows (see following section). In the above example, 

it can be seen that the SampNumb, and Seam are copied from the fields above. 

 

The Copy of Current Unit menu option of the Edit menu makes an identical copy of the row 

above. Beware that this does not create a new row – probably what you want to do is create a new 

row first, otherwise it will overwrite an existing row. You can use the F4 function key to copy 

from the line above, but it ignores blanks. 

This menu option allows you to split a unit in two. For example, you may want to: 

• take a sample in one half, but not the other half of a unit; 

• change the sample number for the same unit; 

• log different weathering characteristics, but all other aspects are the same. 

 

The Copy of Current Unit menu item also adjusts the thickness of the current row to 0.0, as shown 

below: 
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You can also insert rows from another hole (or Shift+F6). This is similar to the copy and paste 

options that are available in a word processor. The Insert Rows from another Hole option 

displays the dialog below.  

 

It allows you to specify: 

• the hole from which the data is to be copied, 

• the interval that is to be inserted. 

 

The new rows are inserted above the current row. In the example above, intervals from 190.00 

to 195.00 from hole AVC031C will be inserted in the log for hole AVC030. One of the reasons 

for inserting rows from another hole is that the second log of the same hole may have been 

completed in more detail after gas bomb testing. 

 

7.3.2 Insert Rows After 

The Insert Rows After menu option provides the same options as Insert Rows Above, except 

that new rows are inserted after the current row. 

 

7.3.3 Append Rows 

The Append Rows option of the Edit menu enables the user to add a new record to the end of the 

currently selected hole. The Append Rows option, as with the Insert Rows option, copies down 

fields from columns above the new row. The user can control which columns are copied by 

going to the Settings menu, then selecting Carry Fields (see following section). 
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An alternative way to add a new record to the end of the hole is to 

page down to the last row, then press the Down Arrow key. 

The figure on the right displays the editor after appending a row. 

In the first column of the last row, a large + sign is displayed to 

indicate the new row.  

 

 

7.3.4 The Carry Fields Option 

The Carry Fields option of the Settings Menu allows you to choose which fields are copied from 

the previous row, when adding or inserting rows. 

 

 

7.3.5 Deleting Row(s) 

The Delete Row option of the Edit menu will delete the selected rows in the grid. Note that confirmation 

of deleting is not requested. If you have accidentally deleted a number of rows, you can either choose 

the Undelete Rows option or if you have not completed a Save during the current session, exiting 

LogCheck without saving, then re-opening the hole will restore the previous version of the data. 

 

7.3.6 Undeleting Row(s) 

The Undelete Row option of the Edit menu will undelete a row that was previously deleted. 

Confirmation of undeleting is not requested. You can keep selecting Undelete Row to undelete 

one further deleted row back to the start of the editing session. 
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7.3.7 Making Fields Blank 

Pressing the Delete key in a numeric field turns the number into 0.0. Blank data in the depth 

field indicates line continuation. If you want to convert a numeric value, including 0.0 into a 

blank, highlight the field and select the Blank Field option from the Edit menu. 

7.3.8 Copy Field from Above 

The Copy Field from Above option searches up the currently selected column to find the first 

non-blank entry, and then copies it to the current row. You can use the F4 function key to copy 

from the column above, but it ignores blanks. 

This option is often useful when adding seams or sample numbers into already entered data. 

7.3.9 The Find Option 

The Find option of the Edit menu (or Ctrl+F) allows you to find values in a specified column. 

The dialog below allows you to specify values to find and the field (column) to find it in. 

In the example 

shown, 

repeatedly 

clicking the Find 

Next button in 

the Seam 

column will 

search for the 

next occurrence 

of “WK2”. 

 

 

 

7.3.10 The Find and Replace Option 

The Find and Replace option of the Edit menu (or Ctrl+H) allows you to search for specific 

values and replace them with something different.  

The dialog requests the 

Field in which to search, the 

value to be replaced, and 

the value to replace it with. 

Clicking the Lookup 

Dictionary button allows 

you to select a valid 

replacement entry.  

The Replace button replaces 

the next entry found. The 

Replace All button searches 

for, and replaces all values. In the example shown, all occurrences of Horizon “BUQA”  will be 

replaced with “BUTE. 
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The Find and Replace, and the Replace options in the Edit menu are the only ones that operate 

when you have multiple holes open. You could use this, for example, if you decide to change 

your seam nomenclature so that all instances of “BUQA” are changed to “BUTE”. 

All of the changes you make are made to temporary copies of the hole data – the changes are 

not made permanently until you save the data. 

 

7.3.11 The Replace Field Option 

The Replace Field option of 

the Edit menu allows you 

replace all entries for a single 

hole between two depths. The 

replacement value can be 

either: 

• A blank 

• A value selected from the 

dictionary 

• Manipulating numerical 

values 

• Expansion/Contraction. 

 

 

 

 

 

7.3.11.1 Replacing with a Blank 

As an example of replacing with a blank, consider the common case of a hole that starts out as 

weathered, then goes to slightly weathered, then fresh, that repeats for the rest of the hole. This 

clutters the reporting – as all subsequent intervals will generally be fresh, so the solution is to 

replace the remainder of core logged as fresh, with a blank. 
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7.3.12 Replacing with a Value from the Dictionary 

This option allows all values between the specified depths to be replaced with another value 

from the dictionary. In the Replace Field dialog (below left) the From depth is specified as 

294.75, the To depth 295.68, and all values for the current column (Seam) are to be replaced 

with WK1. 

 

 

 

 

 

 

 

 

 

7.3.12.1 Manipulating Numerical Values 

The Replace Field option is useful for manipulating numerical values. Coal geologists spend a lot 

of time matching depths in the geology file to depths recorded in geophysical logging of the hole. 

For example, if you wanted to raise the depth of all intervals between depths 47.00 and 61.00 by 5 

cm you would select third option from the “Replace with” list and enter 1.000 in the first box(this 

subtracts 0.05m from each depth over the specified interval), as shown below. 

The figures shown below are an example of log data before (on the left) and after the Replace 

example shown above:  

 

 

This shows the result of replacing 

seam WK2 with WK1 between 

294.75 and 295.68. After the Replace 

button is clicked, LogCheck will 

update the log and inform you of the 

number of rows that were replaced. 

Click the Close button when finished. 

The figure on the right shows 

the results of the Replace 

operation. The braces indicate 

the same interval, with the 

before values on the left. 

Depths on either side of the 

interval are unchanged. 
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A second application of this would be where 

it has been decided to measure dips with 

respect to the horizontal but you had historic 

data where the dips have been measured 

with respect to the core axis (vertical). In 

this case,  the values can be corrected by 

typing –1.00 for the Old Value, and using 

90 for the + value, as shown below: 

7.3.12.2 Expansion/Contraction 

When matching the geology to the geophysics, it may be necessary to add in a core loss. You 

should try to identify where the core loss occurred, and enter a new row indicating “core loss” 

(KL) for the lithology column. Where the drill core is broken up, it may be impossible to 

identify where the core loss occurred, so you can try to spread the loss over the interval. For 

example, for a depth from 19.00 – 41.50, use the Expand/Contract option. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The effect of the example shown below is to stretch out the data between 19.00 – 41.50 so that it 

is between 19.00 – 42.00. It stretches the depth values and puts the core loss proportionately 

throughout the zone. 

After core has been brought to the surface, expansion may occur; in this case, you could make 

New Value 2 less than Old Value 2, in order to counteract the expansion. 

 

The figure on the left shows the depths before the 

Replace operation. The braces indicate the old 

interval, 19.00 – 41.50, before expansion. 

The figure on the right shows the results of the 

Replace operation. The braces indicate the same 

interval, with the after values. Depths on either side 

of the interval are unchanged. 
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7.3.13 Expansion Option 

There is an option in LogCheck that allows 

or disallows core expansion in the Replace 

Field dialog. This can be set from Settings > 

Options, then selecting the Editing tab, as 

shown on the right: 

If the Allow Core Expansion option is 

checked, LogCheck will permit both core 

expansion and contraction,  otherwise it will 

only allow contraction. The manager may 

wish to turn this off. 

 

 

 

 

7.4 The View Menu 

The View menu allows you to configure 

the way the LogCheck Edi tor Window 

is displayed.  

 

 

 

It contains the following items:  

• Grid Layout – displays the data for multiple records in a scrollable grid; 

• Form Layout – displays the data for a single record in a form; 

• Display Keypad/Dictionary Menu – toggles this on or off; 

• Display/Hide fields – allows you to choose which fields are to be displayed in Form layout. 

• Restore Previous Field Display – allows you to restore previously selected columns. 

 

7.5 The Tools Menu 

The items in the Tools menu are shown in the figure 

on the right: 

The Validate and Compare items in the Tools menu 

are used for hole data, whereas the Sort and Filter 

items are used for audits and summaries. 
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7.5.1 Validate 

The Validate tool checks all data that is currently open and it will re-check all codes against 

those that occur in the dictionary. Validate can operate on a single hole or across multiple holes. 

Validate can be used to re-validate your old data, as newer validation checks may be added in 

later versions of the software. 

Coded values (for example, those for the Lithology column) are only checked against the 

dictionary when you actually enter them. So if you have picked up somebody else’s data by 

copying LogCheck files from one machine to another, then the dictionary that was used when 

the copied data was entered, may be different to the current dictionary, and the copied data may 

therefore  have codes that are not in your dictionary.  

As LogCheck does not re-check the codes when 

saving data, you can save data you have modified 

that contains codes that are not in the dictionary, and 

then open up your dictionary and add them in. 

When you select the Validate item, the dialog shown 

on the right requests where the error report is to be 

sent: 

 

When printing the report to a file, the dialog below requests a file name – the default is the hole 

name. The file is saved to the Exports folder for the project. In this example, the file can be 

found at: 

C:\LogCheck\AVOCA\exports\AVC030C Errors.txt 

 

It is prudent to open 

all holes and 

validate before 

producing reports or 

exporting them to 

another system, 

such as a modelling 

package. 
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7.5.2 Tools – Compare 

The Compare tool can be used to compare two copies of the same data – it allows you to see the 

differences between the two copies. You can compare individual files, dictionaries or all files in 

two specified directories. As with Validate, the output can be sent to Screen, Printer or File. 

 

In the following example, hole AVC030C has been opened in the  LogCheck editor.  Another  

copy of hole AVC030C also exists, and it is desired to find out what, if any differences exist 

between the two files. To compare the two files, go to Tools > Compare, and you will be asked 

to select the file that is to be compared with the current file in the editor, as shown below: 

 

 

 
 

You will then be presented with the dialog that requests where the output is to be sent. 

 

7.5.3 Tools – Column Statistics 

For the currently selected 

column (the one the cursor 

is currently in), selecting 

the Column Statistics item 

of the Tools menu displays 

a summary of the data in 

the column. An example is 

shown on the right for the 

Seam column:  
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7.5.4 Tools – Graphical Editor 

The Graphical Editor is an optional component that allows graphical editing of the data. It 

allows the depths, lithology units, seams, plies and sample numbers to be edited. It is available 

from GeoCheck Pty Ltd. 

 

 

 

 

 

 

 

 

 

 

7.6 Setting Editing Options 

The Options menu of the Settings menu allows you to set options for LogCheck. The Editing tab 

of the Options menu allows you to select: 

• The number of recently used entries in the dictionary – which is displayed on the left side of 

the screen when editing, 

• Whether core expansion is allowed – otherwise it will only allow contraction. The manager 

may wish to turn this off. 

• The maximum core length run allowed in drilling data. 

• The Check rock mass unit depths against geology depths option. If this is ticked, the 

program will check that the depth of every rock mass unit (RMU) matches the depth of a 

lithological unit. If the geological log has been corrected to the geophysical log, this option 

enables the user to check that the RMU depths have also been corrected. 

• The Check Point load depths option – if this is ticked, it checks that any point load sample 

lies entirely within a RMU sample. 

 

7.7 Editing a Dictionary 

A dictionary can be opened in two modes: 

• User mode:  Dictionary entries can only be viewed . 

• Manager mode: Entries can be altered and new entries made. 
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7.7.1 Manager Mode for Dictionaries 

 Each time LogCheck is started it operates 

in User mode.   To change to Manager, 

select Settings > Manager from the 

LogCheck menu. A prompt for the manager 

password will then appear: 

The default manager password is 

“LogCheck” and is not case sensitive. 

Modifying  a dictionary is described in 

Chapter 4. 

 

7.7.2 Adding New Entries 

To add a new entry, open the required dictionary and select the option for a specific category. 

Then click the Edit menu item and select Append Rows. In the example below, the Lithotype 

category has been selected:  

 

 

 

 

 

Then the editor creates a new row at the bottom of the grid, as shown below: 

 

 

 

 

 

These methods of adding new entries and editing existing entries apply to the remaining 

LogCheck dictionaries. Most dictionary categories are stored in alphabetical order, however, 

some systems, some categories, such as weathering, or estimated strength may be entered in a 

more appropriate order such as degree of weathering or strength. 

For categories in alphabetical order, there is no insert option. To insert items, just add them to 

the bottom of the list, and LogCheck will automatically move each entry to the appropriate place 

once it has been entered. 

 

A + sign indicates the 

new row; a new entry, 

BA (Basalt) has been 

added 
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Chapter 8  
Audits, Summaries and Total Statistics 

 

 

 

By the end of this chapter you will be able to: 

 

� Audit LogCheck data. 

� Summarise LogCheck data. 

� View total statistics. 

� Sort and filter data. 

 

 

8.1 Introduction 

Audits of drill holes are performed to verify the consistency and accuracy of the data, as 

opposed to the Summary data, which is usually information that you want to use somewhere 

else. Sorting and filtering data are also described. The audits, summaries and total statistics 

available in LogCheck are: 

Audits Summaries Total Statistics 

• Projects • Hole completion • Coded data totals 

• Dictionaries • Drilling • Total thickness by value 

• Codes • Seam/Horizon Picks • LAS variables 

• Total Depths • Seams  

• Uncorrelated coals • Plies  

• Unsampled coals • Samples  

• Unsampled seams • Defect spacing  

• Horizons • Fracture frequency  

• Strats • Point load indices  

• Seams   

• Plies   

• LAS files   
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8.2 Audits 

To access the Audit menu select the File menu, then Open, to display the following: 

 

 

 

 

 

 

 

 

 

 

 

8.3 Project Audits 

A Project audit will display a list of all projects on your computer.  If you have a number of copies 

of LogCheck on your computer for handling different data formats, it only displays the projects for 

the version that you are currently using. This is useful to see quickly if you have the same number 

of holes for each data type and that these match the number of holes that were drilled. 

In the above screen shot, the column headings show each of the different data types and the 

number of holes for that data type, up to the Scanner column. 

The last five columns (Hole Set, Interval, PlanPara and PlotPara and GraphEditPara) display the 

number of definitions of each type that have been stored in the project. For example, for the 

Demo project, there are two hole sets and three interval definitions. 
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8.4 Dictionary Audits 

A Dictionary audit analyses the selected dictionary and find out how many times a code has 

been used in a dataset in the current project. The steps required are: 

1. Select the required dictionary. 

2. Select the holes to compare to the dictionary. 

From the Audit menu, 

select the Dictionary 

item. The Select 

required Dictionary 

dialog is then  

displayed. This allows 

you to select the 

Project, the Data Type, 

and options to select All 

categories or a specific 

category.  

 

In this example, the 

Colour category has 

been selected for the 

Geology dictionary, 

sorted by code. 

 

 

The Select Holes dialog is then displayed: 
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The audit of the colour 

dictionary for all holes in 

the Demo project is then 

displayed: 

A dictionary audit is 

useful when cleaning up 

dictionaries so that you 

can see if a code has been 

used at all, before 

deleting it or combining it 

with another code. 

You can delete a code 

from a dictionary, even 

though it may be in use – 

the system will allow this. 

Then when an audit is run for that code, it says “MISSING FROM DICTIONARY”. 

8.5 Code Audits 

A Code audit  shows where a particular dictionary 

code has been used in a selected group of holes.  

From the Audit menu, select the Codes menu item. 

This displays the standard Hole Selection dialog, 

then the dialog on the right that requests the category 

of code, and within that category, you can select one 

or more of the available codes: 

 

 

 

 

 

For the above example, with 

category of Lithotype and code 

CO, the following audit is 

displayed: 
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You can also select more than one code to analyse, 

using standard Windows selection mechanisms: 

• To select adjoining codes, firstly hold the 

Shift key down, click the first code, and then 

click the last one in the selection. 

• To select codes that are not adjacent, firstly 

hold the Control key down, then click each  

code that is required. 

 

In the example on the right, for the Lithological 

Qualifier category, two codes are being audited 

(DB and DM). 

 

 

 

 

The resulting 

audit shows 

that the same 

code has been 

logged in each 

of the three 

qualifiers:  

 

 

 

 

8.6 Total Depth Audits 

A Total Depth audit shows the total depth in each data type of the selected drill holes. A Total 

Depth audit will enable you to 

spot where data may have not 

been entered. For example, the 

top part of a hole may have been 

entered, but the lower part, which 

may have been recorded on a 

different day or by a different 

geologist, may accidentally not 

have been entered. Selecting Total 

Depths from the Audit menu then 

displays the standard hole 

selection dialog. The results of the 

audit areshown on the right: 
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As an example, if the Drill Hole data ends at 179.80m and the Geology at 202.06 m, it suggests 

that there may be missing Drill Hole data. If there is no data, it shows up as a blank field. A 0.0 

in the Header data means that the Header data is there, but the total depth field has not been 

filled in. 

It is important to check that the Geophysics log is the same as the Geology – this may not be the 

case, due to hole cave in. The LAS Step column can have multiple values for the same hole, for 

example one at 0.05 cm and one at 0.01 cm intervals. The LASTTOP and LASTBOT columns 

are the top and bottom depths that the LAS data was logged. 

8.7 Uncorrelated Coals 

The Uncorrelated Coals audit analyses each hole and shows the top and bottom depth of each 

seam. It then shows any instances of coal that occur between the seams. It also shows the 

thickness of the seam, so that you can determine how significant it is. If the unit consists of only 

one coal lithology it shows it, otherwise it just shows CO. 

The Perc column is the 

Percentage column and 

shows the percentage of the 

unit that was coal (if a 

lithology is coal from the 

Group column in the 

dictionary). 

The Uncorrelated Coals audit 

initially allows you to select 

the required holes from the 

standard Hole Selection 

dialog, then a form similar to 

the following is displayed: 

8.8 Unsampled Coals 

The Unsampled Coals audit analyses each of the selected holes and shows the intervals where 

coal has been logged as a lithology, but for which no sample number exists. Again, it 

determines that a lithology is coal from the Group column in the dictionary. 

The Unsampled Coals audit initially 

allows you to select the required holes 

from the standard Hole Selection 

dialog, then a form similar to the 

following displays the details of coals 

that have not yet been sampled: 

If there is only one type of lithology 

in the uncorrelated coal, it shows it, 

otherwise it just shows CO. It 

determines if a lithology is coal from 

the Group column in the dictionary. 
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8.9 Unsampled Seams 

The Unsampled Seams audit 

analyses each of the selected holes 

and shows seams for which no 

sample number exists. 

The Unsampled Seams audit 

initially allows you to select the 

required holes from the standard 

Hole Selection dialog, then a form 

similar to the following displays the 

details of seams that have not yet 

been sampled: 

 

8.10 Horizons, Strats, Seams and Plies 

In some LogCheck formats, Horizons, such as Base of Tertiary, are stored in the seam column 

of the geological data; on a unit with the same base depth as the preceding unit and blanks in all 

the remaining columns. Other LogCheck formats, such as CoalLog have separate Seam, Ply and 

Horizon columns. 

Horizon, strat and seam audits are all similar in the output format. The Seam column can also 

include Strats – a strat is a unit that is to be used for correlation purposes, as opposed to a seam, 

which only refers to a coal. Seam/Horizon/Strats are specified in a project-specific 

Seam/Horizon dictionary. For the Seam audit, it shows the thickness of the seam, as opposed to 

the depth for a horizon. 

In each of these three, each row is a hole and each column is a horizon/seam or strat from the 

dictionary, but it only shows those that occur in at least one of the holes you have requested. 

This can be used to identify missing horizons, for example, if there is no Base of Tertiary in a 

particular hole this could be because the geologist forgot to identify it, or this hole may have 

been in rock the whole way. 

The audit can show up where a seam is missing from a hole and it can also show up where a 

seam is atypically thicker or thinner than other instances of that seam. 

8.10.1 Horizon Audit 

From the Audit menu, select the Horizons 

menu item. This initially displays the 

standard Hole Selection dialog. An 

example of a Horizon audit is shown on 

the right. Each horizon has its own 

column – in this case, there are three: 

BHWE, BHWL and BUTE 
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8.10.2 Seam Audit 

From the Audit menu, select the Seam menu item. This initially displays the standard Hole 

Selection dialog. An example of a Seam audit is shown on the right: 

 

 

8.11 LAS Files Audit 

The LAS file audit goes through all selected holes and specifies for each LAS file, the hole, 

from and to depths, step, and service company (SRVC). 

Often, there will be a multitude of LAS files; there may be numerous LAS files even for a single 

hole, as there may be separate LAS files for different reading intervals, geophysical tools and/or 

sections of the hole. It is often difficult for the logger to incorporate the hole name, reading 

interval, tool and section of the hole all into the file name. 

When you need the LAS data for a specified variable, hole and depth LogCheck determines the 

required file from the LAS Audit table. In order to do this though, the Well line in the LAS file 

should contain the hole name as is being used in LogCheck 

From the Audit menu, select the LAS Files menu item. This initially displays the standard Hole 

Selection dialog. An example of a LAS Files audit is shown below:  
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8.12 The Summary Menu 

Summaries can be conducted for: 

• Hole Completion, 

• Drilling, 

• Seam/horizon Picks, 

• Seams, 

• Plies, 

• Samples, 

• Defects, 

• Defect Spacings, 

• Fracture Frequency, 

• Point Load Indices. 

 

To access the Summary menu select the File menu, then Open, to display the following: 
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8.13 Drilling Summary 

The Drilling Summary displays the type of drilling that was done for each hole. This initially 

displays the standard Hole Selection dialog. An example of a Drilling Summary for all holes is 

shown below: 

 

 

The columns for this summary are: 

• Hole: Hole number, 

• Start date: Start date of drilling, 

• End date: End date of drilling, 

• DrC: Drilling company, 

• RNo: Rig number, 

• BT_A: Roller bit drilling, 

• BT_B: Blade bit drilling, 

• BT_C: Tungsten coring bit drilling, 

• BT_D: Diamond coring bit drilling, 

• BT_E: Hammer bit drilling, 

• BT_P: Polycrystalline diamond bit drilling, 

• BT_Unknown: Unspecified bit drilling, 

• Total: Total depth of drilling. 

 

Note: where a hole has had more than one drilling company or rig operating in the hole a 

separate line is shown for each drilling company/rig combination. To calculate total meterage 

for different bit types over a set of holes, open a drilling summary for these holes, export it to 

Microsoft® Excel as a comma delimited file (.csv) and then sum the columns in Excel. 

 

 

These depend on the 

entries that are in the 

Drilling dictionary. 
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8.14 Seam/Horizon Picks 

The Seam/Horizon Picks summary allows you to choose combinations of the following: 

• Horizons, 

• Strats, 

• Seams, 

• Plies 

 

Navigating the menu to the File > Open > 

Summaries > Seam/Horizon Picks menu item 

initially displays the standard Hole Selection 

dialog. This is followed by the Seam/Horizon 

Picks dialog, shown on the right: 

Note that the Plies option only appears if you 

have a Ply column in your data format. 

 

An example of a Seam/Horizon Picks summary is displayed on the right: 

 

 

 

 

 

 

 

 

 

The columns for this summary are: 

• Hole: Hole number, 

• Unit: The Horizon/Strat/Seam/Ply name, 

• From: From depth of unit, 

• To: To depth of unit, 

• Thick: Thickness of the unit. 
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8.15  Seam/Plies Summary 

The Seam Summary displays a summary of the seams occurring in each hole. For this summary, 

navigate to the File > Open > Summaries > Seams/Plies > Seams menu item (if Plies is chosen, 

it works on the Ply column, not the Seam column), as shown below: 

 

 

 

 

 

 

Initially, the standard Hole Selection dialog is displayed. This is followed by the Seam 

Summary Parameters dialog as shown below: 

 

When deciding whether a unit is coal or partings, you can specify a minimum parting thickness 

in this dialog. This is significant, because when mining coal, anything less than this thickness 

that is not coal, can’t be separated from the actual coal, and is included with the coal.  
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The coal density is required, in order to calculate the strip ratio, although this is irrelevant for 

underground mining. In LogCheck, there are two ways to specify the density: 

1. Using an estimated density for all coal and one for all stone. 

2. Using LAS density. In the example above, there ino LAS data is available, so this option 

is greyed out. 

The Seam Summary for all holes is shown below (left-hand section): 

 

The columns for the left-hand section of the Seam Summary are: 

• Hole: Hole number, 

• Seam: Seam name, 

• From: From depth of seam, 

• To: To depth of seam, 

• Thick: The seam thickness – the difference between the From and To depths 

(includes partings and core loss), 

• Coal: Metres of thickness of coal; it determines which lithologies are coal by 

those lithologies that have COAL in the Group column of the dictionary 

(may include core loss – see following section), 

• Partings: Thickness of anything that is not coal (may include core loss – see 

following section, 

• Core Loss: Any part of the lithology that has CORELOSS in the Group column in 

the lithology, 

• Cored: That part of the seam thickness that has a bit type in the drilling data with 

its GROUP set to CORED in the Bit Type dictionary, 

• Recovery: Is the percentage recovery – it is the percentage of the parts of the seam 

that are cored and do not have core loss recorded in the geology. 

8.15.1.1 Determining Whether a Core Loss is Coal or Non-Coal 

When deciding whether a core loss is to be regarded as coal or non-coal, three situations can be 

distinguished, based on whether the core loss is overlain/underlain by coal/non coal: 

Coal  Non-coal  Non-coal 

Core Loss  Core Loss  Core Loss 

Coal  Coal  Non-Coal 

     

1. Core loss is 

regarded as coal 

 2. Core loss is 

regarded as coal 

 3. Core loss is 

regarded as 

parting 
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The right-hand section of the Seam Summary is shown below: 

 

 

The columns are as follows: 

• Coal_Density: Coal density, 

• Coal_Mass: Coal mass per square metre, 

• Burden: Thickness of over/interburden and partings, 

• Strip_Rat: Burden thickness/coal mass (strip ratio), 

• Cum_Coal_Mass: Cumulative coal mass per square metre, 

• Cum_Burden: Cumulative thickness of over/interburden and partings, 

• Cum_Strip_Rat: Cumulative strip ratio (cumulative burden / cumulative coal mass), 

 

8.16 Samples Summary 

The Samples Summary displays a summary of the samples taken for each hole. Navigate the 

menu to the File > Open > Summaries > Samples menu item. Initially, the standard Hole 

Selection dialog is displayed. This is followed by the Theoretical Sample Mass Calculation 

dialog, where densities for coal and stone can be entered, as shown below: 

If the “Calculate …” box 

is checked, a theoretical 

sample mass is calculated 

for each sample by 

multiplying the sample 

length by drill hole cross-

sectional area (derived 

from the core size in the 

drilling data) by a density 

which can either be 

derived by using a 

specified density for each 

of coal and stone or from 

a density from the LAS 

data. The sample mass as 

measured by the 

laboratory can be compared to this to determine a recovery for the sample. 

The cumulative values 

include the combination of 

all the overlying values 
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Clicking the OK button then displays the Sample Summary, as shown below, for all holes (left-

hand section): 

 

The columns for the left-hand section of this summary are: 

• Hole: Hole number, 

• SampNumb: Sample number, 

• From: From depth of sample, 

• To: To depth of sample, 

• Thick: Difference between the From and To depths, 

• Coal: Coal thickness, as determined from the lithologies of the sample and 

which lithologies have their Group set to coal. 

• Core Loss: Core loss thickness – same as above, except that the Group is now CORE LOSS, 

• Cored: Cored thickness – the sample has a bit type in the drilling data with its 

GROUP set to CORED in the Bit Type dictionary, 

• Recovery: The percentage recovery – it is the percentage of the parts of the sample 

that are cored and do not have core loss recorded in the geology. 

 

An example of the right-hand section of the Sample Summary is shown below: 

 

The columns for the right-hand section of this summary are: 

• Seam1: Top seam in the sample, 

• Type1: Top type (roof or floor), 

• Seam2: Bottom seam in the sample, 

• Type2: Bottom type (roof or floor), 

• Date: Date of drilling, as derived from drilling data, 
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• CoSz: Core size, as derived from drilling data, 

• Density: The estimated density of the sample, 

• Mass: Theoretical sample mass – assuming 100% core recovery. 

• Lithology: Summary of lithology based on the group in the dictionary. 

 

Notes: 

1. For the Type1 and Type2 columns, if the sample starts above the seam, ROOF is entered 

in the column; if the sample ends below the seam, FLOOR is entered in the column. 

2. To calculate the density, it uses the Group codes in the lithology in the geology 

dictionary. For example, in the second row of the above example, the density is estimated 

using the pro rata density of 1.40 for the 79% coal, and 2.50 for the remaining 21% stone 

(see previous page). 

 

8.17 Defect Summary 

The Defect Summary displays a summary of the defects occurring in rock mass units. Navigate 

the menu to the File > Open > Summaries > Defect menu item. This summary presents the 

standard Hole Selection dialog. If the All holes option is selected, LogCheck then displays a list 

of all holes that have defect data recorded.  

If the Single hole option is selected, a summary of the defects for that hole is displayed. An 

example is shown below: 

The entries for the defect summary data include: 

• Depth:  The depth to the top of the RMU. 

• RT: Rock mass unit type, for example, SS – sandstone. 

• ST:  Estimated strength, for example, MS – moderate strength rock. 

• We: Weathering, for example, F – fresh. 

• P: Plasticity, for example, P – puggy. 

• Sl: Slaking potential, for example, 4 – moderate slaking. 

• Desc: Description of the RMU. 

• RQD: Rock quality designator. 

• Hans: Hansagi’s C factor. 

• Stick: Average stick length. 

• DT: A defect type within the RMU, for example, BP – bedding planes. 

• Sh: Surface shape, for example, P – planar. 

• Ro: Surface roughness, for example, K – slickensided. 

• DC: Defect continuity, for example, 1 – one end terminates. 
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8.18 Defect Spacing Summary 

The Defect Spacing Summary displays a 

summary of the seams occurring in each hole.  

Navigate the menu to the File > Open > 

Summaries > Defect Spacing menu item. This 

summary presents the standard Hole Selection 

dialog, which gives you a choice of listing all 

holes, or data for a specified hole.   

The dialog on the right allows you to select: 

• Either all defects, a specific defect type or 

groups in the Defect dictionary. 

• An option to include intact defects. 

• An option to include induced defects. 

 

 

 

 

 

 

If all holes was selected, a list of holes 

containing that defect is displayed, as shown 

on the right: 

 

 

 

 

 

 

If a single hole was selected, the depth 

and defec t spacing are displayed, for 

example: 
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8.19  Fracture Frequency Summary 

The Fracture Frequency Summary displays a list of all holes with defect data. Navigate the 

menu to the File > Open > Summaries > Fracture Frequency menu item. 

Initially, the standard 

Hole Selection dialog is 

displayed. If the All 

Holes option is selected, 

it lists all holes where 

fracture frequencies have 

been recorded. An 

example is shown on the 

right: 

 

 

 

 

 

 

Selecting an individual hole, displays the fracture frequency in fractures per metre. The hole is 

divided into intervals between points half-way between defects. An example of a Fracture 

Frequency Summary for a hole is displayed below: 
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8.20  Point Load Indices Summary 

The Point Load Index that is calculated in LogCheck, is a size-corrected value that is the 

equivalent Point Load Index for a sample that would have been measured by a diametral test 

with a diameter of 50 mm.  

The uncorrected point load index
1
  is calculated as follows: 

  I = P / D2 

  Where: 

  I:  Uncorrected point load strength; 

  P:  The load at failure; 

  D: The equivalent core diameter. 

The equivalent core diameter depends on whether the test was: 

(a) Diametral, where D is the core diameter. 

 

(b) Axial, where D is given by the following formula: 

  D = 4 * A / PI 

 Where A is the minimum cross-sectional area of a plane through the platen contact points: 

 A = Core length * Width (perpendicular to the loading direction) 

 

The size-corrected Point Load Strength Index of a sample uses the following Size Correction 

Factor, F: 

 F = (D / 50)0.45 

The size-corrected Point Load Index used by LogCheck is given by the following formula: 

 Is(50) = F * 1000 * (P / D
2) 

 

                                                      
1
  Journal of Geomechanics, Vol. 22, No.2, pp51-60, 1985. “Suggested method for Determining Point 

Load Strength” 

For a diametral test, if the sample length 

is less than the diameter, a value for the 

point load index is not recorded 

For an axial test, if the sample length is 

greater than the diameter or the length is 

less than 0.3 of the diameter, a value for 

the point load index is not recorded 
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The Point Load Indices Summary displays a list of all holes with point load data. Navigate the 

menu to the File > Open > Summaries > Point Load Indices menu item. 

Initially, the standard Hole 

Selection dialog is displayed. If the 

All Holes option is selected, it lists 

all holes where point load data is 

available. An example is shown on 

the right: 

 

 

 

 

 

 

 

 

Selecting an individual hole will display the point load indices for the hole, for example: 
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8.21 Statistics 

The Statistics menu is opened by selecting File > Open > Statistics. The Statistics menu is as 

shown below: 

 

 

There are three items on the Statistics menu: 

• Coded Data Frequencies, 

• Interval Thickness Statistics for a Specified Value,  

• LAS Variables. 

 

 

For the Coded Data 

Frequencies 

summary, the 

standard hole 

selection dialog is 

displayed, then the 

Select parameters 

dialog:  

A second variable can 

optionally be 

selected. The 

statistics can be 

produced either on 

the actual value of the 

variable, or its value 

in the Group column 

in the Dictionary. 
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The following is an example of the Coded Data Frequency summary. It lists the frequency of 

occurrence of each of the lithotype codes for each hole that was selected: 

 

8.22 Tools – Sort 

The Sort item of the Tools menu is only enabled when you are opening an audit, summary or 

statistics. These can be sorted by up to four variables. In the following Seam Summary example,  

from the main menu, select Tools > Sort, and the following dialog is displayed: 

 

In the drop-down list, select the required sort fields, as shown below, then click the OK button: 
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8.23 Tools – Filter 

The Filter item of the Tools menu is only enabled when you are opening an audit, summary or 

statistics. These can be filtered by an expression. In the following Seam Summary example,  

from the main menu, select Tools > Filter, and the following dialog is displayed: 

 

In the above example, the results are filtered so that only those records where the seam name is 

“MAU” and the thickness is greater than, or equal to, 1 metre, are displayed. 
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Chapter 9  
 Printing and Exporting 

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Set LogCheck reporting options. 

� Print a data report. 

� Print a descriptive report. 

� Export data to other file formats. 

 

 

 

 

 

9.1 Introduction 

LogCheck reports are available on all data entered into the system. The reporting options allow 

you to print a report on the data that is currently displayed in the LogCheck editor. For example, 

if hole geology is displayed, selecting the File > Print > Report option will print that data or if a 

summary is displayed, then it will be printed. 
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9.2 Printing 

LogCheck When a report menu option is chosen, a printer selection dialog is displayed, for example: 

In addition to hard copy of a 

report, it is also useful to install 

a PDF (Portable Document 

File) printer so that reports can 

be emailed. In the this dialog, 

PrimoPDF has been selected as 

the printer. PrimoPDF is a free 

software utility that prints the 

selected data to a PDF file. It 

can be downloaded from: 

www.primopdf.com 

 

 

 

9.3 Reporting Options 

From the Options menu, the Reporting tab allows you to specify the number of lines in a page – 

for both portrait and landscape orientation. 

For exported reports, the page length 

can be specified, and the dash symbol, 

can be one of:  

• the Em dash (the long dash – ),  

• the En dash (the short dash -) or 

• some other symbol. 
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9.4 The Reports Menu 

To access the Reports menu select 

the File menu, then Print, to select 

either the Data or Report option: 

 

 

 

 

 

 

 

 

9.4.1 Data Report 

If the Data option is selected, a report is generated that displays the data in columns. For coded 

data fields, the actual code values are displayed. An example is: 
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9.4.2 Descriptive Reports 

If the Report option is selected, a report is generated that displays the data in columns. For 

coded data fields, the actual code values and their descriptions are displayed. An example is: 

 

9.5 Exporting Data 

The exporting menu is as follows: 
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The Export Data dialog is 

then displayed: 

 

 

 

 

 

 

 

Next, a dialog for selecting 

additional data for inclusion 

in the report is displayed: 

 

 

 

 

 

 

 

Next, a dialog for selecting 

fields to include in the 

exported file is displayed: 
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Next, a dialog 

that requests the 

location and 

name of the 

exported file is 

displayed. The 

default location 

is the Exports 

folder of the 

current project: 

 

 

 

 

 

 

Finally, confirmation of the data 

export is displayed: 

 

 

 

 

The exported 

file can then be 

opened in other 

applications, 

such as 

Microsoft 

Excel: 
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Chapter 10  
Plotting 

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Open, create and save a plot definition file. 

� Set parameters for sections and title blocks. 

� Add, insert, and delete tracks for a plot. 

� Plot a hole or a section. 

� Plot the LAS data by appending to an existing plot file. 
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10.1 Introduction 

LogCheck provides  a wide variety of options for plotting hole logging data. There are many 

variations and parameters that define the appearance of the plot. Not all of them are covered 

here – you may need to experiment in order to obtain the output that you require.  

All plots are generated as AutoCad release 12 DXF files (note that Release 12 has no facilities 

for bitmaps or JPEG files). Many freeware packages and most CAD packages can display and 

plot these files.  We recommend AutoCad’s TrueView to display the plot file. TrueView is 

available free and can be downloaded from (at the time of printing): 

http://usa.autodesk.com/adsk/servlet/pc/index?id=6703438 

The plot layouts are defined by the user in LogCheck files known as plot definitions. These 

include such things as the vertical scale, the width, location and contents of columns known as 

tracks) on the plot, the horizontal scale, and items to be shown in the title block. When the user 

plots their currently open data, they are prompted for the name of the plot definition to be used 

to plot their data. 

LogCheck comes with a standard list of plot files. These are described in Appendix B and 

include: 

• A seams only plot at 1:20 
• Entire hole with Geophysics (Density Gamma and Calliper) 

• 1:20 plot of individual holes in A4 and A3. 

• 1:100 plot of individual holes in A4 andA3. 

• 1:200 plot of individual holes in A4 and A3. 

• A4 and A3 section plots without horizontal scale (ie sit 10 mm apart for a fence 

diagram) at 1:100 and 1:200. 

 

10.1.1 Plot Definition Files 

The plot parameters are stored in a plot definition file. When LogCheck looks for plot definition 

files, it searches the following folders in this order: 

1. PlotPara in the current project folder. 

2. PlotPara under \LogData. 

3. PlotPara under \Program Files\LogCheck – this is distributed with the software. 

Any modifications are saved in folders (1) or (2). A plot definition consists of three files with 

extensions .BBF, .DBF, and .MEM. For example, the GEOLASPR plot definition in the above 

selection is made up of these three files: GEOLASPR.BBF, GEOLASPR.DBF and 

GEOLASPR.MEM. These three files can be renamed, deleted or copied to another location. 
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10.2 Plotting a Hole 

When plotting a hole in LogCheck, the steps generally 

are:  

• Select the hole to be plotted. When selecting the 

hole, the user can select the entire hole, a depth 

interval or seam. 

• Go to the File > Plot menu. The user will then be 

asked to select a plot, as shown on the right: 

This lists every plot definition file available to 

LogCheck. These include the standard LogCheck 

plots that start with LC, those that are available in 

C:\LogData\PlotPara, and those stored with the 

project.  

 

 

 

 

 

 

 

 

• Save the plot file. 

LogCheck asks the user 

for a file name.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• If a plot file of that name already exists, LogCheck ask whether to overwrite the file, or 

append the current hole to data that is already in the file. 
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If one of the Append options is chosen, the data is added to the existing plot; if one of the 

Overwrite options is chosen, the data in the file is deleted and a new plot is created. We can also 

select a seam for a hole and plot it, in which case the plot file is named as 

HOLENAME_SEAMS.dxf. 

10.3 Creating a Plot Definition File 

A new plot definition can be created by going to File > New > Plot Definition (or pressing the 

Ctrl+F11 keys), as shown below on the left. In the figure below, a new plot definition will be 

created specific to the AVOCA project, and its name will be GEOLASPR. 

 

 

 

 

 

 

 

In the figure on the right, a new plot 

definition will be created specific to 

the TRAINING project, and its name 

will be GEOLASPR. 

 

 

 

 

10.4 Opening Plot 

Definition Files 

A plot definition file can be opened by 

going to File > Open > Plot Definition. This 

initially displays the following dialog that 

allows the selection of the plot definition 

file: 

This form allows you to choose either a 

default plot definition, or one that is specific 

to the project. Choose the required plot 

definition, then click the OK button (hidden 

in the above diagram). 
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10.5 Copying a Plot Definition File 

An existing plot file can be copied to another plot file – and presumably this will then have 

some modification that wasn’t present in the original definition. To copy a plot file: 

1. Open an existing plot file. 

2. From the File menu, select Save As (as shown on the left). 

3. Enter a new name for the plot (as shown on the right). 

 

  

 

 

 

 

 

 

 

10.6 The Plot Definition Form 

An example of the Plot Definition form is shown below: 
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The tabs in this form and their purpose are: 

• General:  Set options for the DXF template file, how to draw the hole name 

and depth bars, page layout and vertical bars. 

• Sections:  Set options for drawing sections. 

• Border/Title Block:  Set options for drawing the border and title block. 

• Tracks:  Set options for the location and content of the various tracks that 

are to be drawn on the plot. 

 

10.7 General Tab 

The parameters that can be set in the General tab (which is shown on the previous page) include: 

• The DXF template file, 

• The vertical scale, 

• Page layout – such as maximum track length and number of repetitions, 

• Options on how and where to position the name of the hole on the plot, 

• Depth bar formatting. 

 

10.7.1 DXF Template File 

When LogCheck creates a DXF file, it builds on another 

DXF file – that is, the DXF template. If this field is left 

blank, LogCheck uses its own default template, called 

LogCheck.dxf. However, the user can specify another 
template in this field. DXF template files are stored in the folder \Program 

Files\LogCheck\PlotPara. The search path for DXF template files is the same as for the plot 

definition files 

The file LogCheck.dxf. is an empty DXF file that contains setup data only and does not contain 

any graphics commands. The user can set up their own DXF file template. This allows you to 

set up your own default legends and title block for plots. LogCheck can now produce a simple 

title block. 

10.7.2 Vertical Scale 

Vertical scale is the vertical scale used to plot the 

log data. The vertical scale is specified in the 

General tab In order to get the scales that you have 

set up in LogCheck to work as they are meant to in 

TrueView/AutoCad, in TrueView printer setup, you 

must have the plot scale set up so that 1 mm  = 1 

unit, as the drawing unit in LogCheck is always  

millimetres. 

In LogCheck > Options > Plotting tab, the scale 

format can be set as either metric or ratio, as shown 

on the right. For example, if metric 1 metre (on 

ground) =  20mm on paper, the ratio for this is 1:50. 



CHAPTER 10. PLOTTING 

128  LogCheck Manual 

 

10.7.3 Page Layout Panel 

The Page Layout panel of the General tab has parameters that control the maximum track length 

and distance between repetitions. These parameters only apply when a single hole is being plotted 

(they do not apply if a section is being plotted – in this case, these values are set in the Sections 

tab).  

The page layout parameters 

are displayed on the right: 

 

 

10.7.3.1 Maximum Track Length 

The maximum track length is the maximum amount of hole that will be displayed going down 

the page. 

10.7.3.2 Maximum Number of Repetitions 

The maximum number of repetitions is the maximum number of times that a track is repeated 

across the page.  

If there is a part of the hole left over, LogCheck writes the plot data into separate DXF files, 

identified by the hole name and a letter. For example if the hole name is D1234, and there are 

multiple plot files, the default names of the plot files are D1234A.dxf, D1234B.dxf, 

D1234C.dxf. If there are more than 26 files, the 27
th
 would become D1234AA.dxf. 

10.7.3.3 Distance between Repetitions 

Where there are repetitions of the track across the page, this specifies the distance between them 

in millimetres. 

 

The page layout example 

above would plot 6 logs 

across the page separated 

by 40mm. The first log is 

from 0-8m, the second 

from 8-16, etc. 
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10.7.4 Positioning of Hole Names 

The hole name positioning parameters determine how the hole name for each hole is placed on 

the plot. This panel is located in the General tab, and is shown below: 

 

10.7.4.1 Plot Hole Names 

If this checkbox is checked, the hole number is printed on the plot, otherwise it is not. 

10.7.4.2 Horizontal Offset from Hole 

The horizontal offset is the offset from the 0 X coordinate where the hole name 

will be printed. In the example on the right, the width of the log is 10mm, the 

ho, the 0 X coordinate is the left hand edge of the log. Where the Justification 

is set to Centre, it references the bottom of the hole text. 

 

10.7.4.3 Vertical Offset from Hole 

The vertical offset is the offset from the 0 Y coordinate where the hole name 

will be printed, as shown on the right. 

10.7.4.4 Justification 

Justification relates to placement of text relative to the horizontal offset; it can 

be either Left, Right or Centre.  

10.7.4.5 Text Height 

Text height is the vertical size of the text in millimetres. 

10.7.4.6 Orientation 

The orientation is the angle from the horizontal that the text will be printed. For example, a 

value of 0 will display the hole name horizontally, and a value of 90 will display the text 

vertically. 

10.7.4.7 Style 

The Style parameter is not currently used. 

DDH001 

DDH001 

0 X coordinate 
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Examples of changing the position of hole names are shown below: 

• Justification set to Centre,  

Horizontal offset set to 5 mm: 

 

 

 

 

 

 

• Justification set to Left 

Horizontal offset set to 5 mm:  

 

 

 

 

• Justification set to Left 

Horizontal offset set to 0 mm:  

 

 

 

 

 

 

 

 

• Orientation set to 90,  

justification set to Left 

Horizontal offset set to 5 mm: 
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10.7.5 Depth Bars 

Depth bars determine how the depth and RL ticks are formatted on the plot. The Depth Bars 

panel is located in the General tab. Depth bars can be added to the end of the existing depth bar 

rows, or deleted by accessing the Edit menu. To append a track, go to Edit > Append Rows, and 

a new track is added to the grid. When a Depth Bar is appended, it copies the values from the 

previous row down to the new row. 

 

 

10.7.5.1 Hole 

The options are Left, Right or All. This specifies whether the depth bar goes on the left or right 

side of the hole plot. Adding extra rows adds an additional depth bar to the plot. 

10.7.5.2 xOrig 

The xOrig column specifies the position of the depth bar. A value of 0 means that the depth bar 

will be plotted down the left hand edge of the lithology pattern, and extending to the left. If the 

lithology pattern is 10 mm wide, the second line in the above example means that the RL 

(reduced level).will be plotted down the right side of the pattern, with the bars going to the right. 

10.7.5.3 Variable 

The variable that is plotted can be either the depth down the hole, or the RL 

10.7.5.4 Title_Hgt 

The Title_Hgt column specifies the height of the title (either “Depth” or “RL”) that appear on 

the depth bar. 

10.7.5.5 Tick_Side 

The Tick_Side column specifies whether the ticks are drawn to the left or right hand side. 

10.7.5.6 Tick_Step 

The Tick_Step column specifies how much of the log is represented by the distance between 

two ticks. For example, a value of .2 means that a tick will be placed every .2 m. 

10.7.5.7 Tick_Size 

The Tick_Size column specifies the length of a tick in millimetres.. 

10.7.5.8 Annot_Step 

The Annot_Step column specifies where the numbers are printed – as not every tick has a 

number. 

10.7.5.9 Annot_Hgt 

The Annot_Hgt column specifies the height of the numbers that appear on the depth bar. 
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10.7.6 Examples of Settings in the General Tab 

For the previous plot definition 

(GEOLASPR), the resulting plot looks 

like: 

Note the “Depth” on the left of the plot, 

and “R.L.” on the right side of the plot. 

The tick step is 0.2, giving 5 to the metre, 

and the Annot_Step is 1.0 metres. 

There are three repetitions across the 

page. 

 

 

By altering the previous plot definition so that the for the Depth variable, the Hole parameter is 

changed to All, 

 

 

 

 

The following plot results. Notice that 

now all repeat sections have the depth 

bars on them: 

 

 

 

 

 

 

 

 

Note: the above plot requires that in the Sections tab (described in the following section), the 

Vertical Alignment needs to be set to Top of displayed interval. 
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10.8 The Sections Tab 

The Sections Tab sets parameters to be used when plotting sections. The three panels in this tab  

are: 

• Vertical alignment. 

• Horizontal alignment. 

• Stratigraphy – for connecting between adjacent holes. 

 

 

 

 

 

 

 

 

 

 

 

 

10.8.1 The Horizontal Alignment Panel 

The Horizontal Alignment panel of the Sections Panel allows either a scale ratio or a fixed 

interval to be chosen for the plot. 
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10.8.2 The Vertical Alignment Panel 

The Vertical Alignment panel allows the holes to be aligned by: Hole Elevation, Top of displayed 

interval, Bottom of displayed interval, or a level chosen from the data, as shown below: 

 

 

 

 

 

 

10.8.2.1 Alignment by Hole Elevation 

An example of vertical alignment by hole elevation is shown below: 

 

 

 

 

 

 

 

10.8.2.2 Alignment by Top of Displayed Interval 

An example of vertical alignment by top of displayed interval is shown below: 

 

 

 

 

 

 



CHAPTER 10. PLOTTING 

 LogCheck Manual   135 

10.8.2.3 Alignment by Bottom of Displayed Interval 

An example of vertical alignment by bottom of displayed interval is shown below: 

 

 

 

 

 

 

 

 

10.8.2.4 Alignment by Level Chosen From Data 

Vertical alignment can also be specified by a level chosen from the data. By specifying 

“SEAM=”J”, the connections are aligned to the top of this seam: 
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10.8.3 The Stratigraphy Panel 

The Stratigraphy panel of the Sections tab allows the stratigraphic units to be chosen for 

connection between the holes on the section. Connections between holes can be made on the 

basis of Horizon, Strats or/and Coal Correlations (Seams, Plies or Seams+Plies): 

 

 

 

 

 

 

Horizontal offsets can be specified for holes on the left and right hand side of a connection. 

If connections are drawn between holes (eg the Seams box is 

ticked), the Horizontal offset alters the position where the 

connecting lines are drawn on the lithology column. The effect 

of this value can be seen in these two examples. 

(a) Horizontal offset set to 0 mm – the connecting 

lines start at the left edge of the lithology 

column. 

 

 

(b) Horizontal offset set to 5mm – the 

connecting 

lines start 5 mm from the left edge of the 

lithology column. 
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The following example shows the seams connected, and with the Colour box ticked: 

 

 

 

 

 

 

 

 

 

 

 

The following example is the same as the previous plot, except that the Colour box was not 

checked: 

 

 

 

 

 

 

 

 

 

 

To plot a section: 

• Define the holes that will be plotted on the section. (File > New > Hole Set Definition), if it 

doesn’t already exist.  

• Then open the hole data for that section (File > Open > Hole Data). 

• Generate the plot file (File > Plot). 
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10.9 The Border/Title Block Tab 

The Border /Title Block tab allow the user to draw a border around the plot, and specify the 

position of the title block and its entries. For a new plot definition, this tab is shown below: 

 

If the Plot Sheet Border box is checked, the remaining fields in the Sheet Border panel are 

enabled. The orientation of the plot and position of the border relative to the top left hole can be 

specified.  

10.9.1 Specifying Title Block Text Entries 

The title block of a plot is made up of a number of fixed panels where you can place text 

relevant to the plot. Text entries can be added to the title block by specifying the text type and 

its location, inserted between existing tracks or deleted by accessing the Edit menu. To insert a 

text entry, select  Edit > Insert Rows Above/Below or Append Rows, and a new track is added 

to the grid. Alternatively, when on the last row, press the down arrow key to add a new blank 

row. 

Each row has the following values: 

• Text_Type:  The text type of the entry. This column displays a drop down box with 

the available LogCheck variables that can be displayed in the title block. 

• Text_Value:  For the Text_Type “Specify”, you can enter some arbitrary text in this 

column. 

• Text_X:  The X coordinate of the text relative to the plot. 

• Text_Y:  The Y coordinate of the text relative to the plot. 

• Text_Just:  The text justification (left, right or centre). 

• Text_Hgt:  The height of the text in mm. 
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• Text_Ang:  The angular rotation of the text. 

The panels in the default title block are fixed, and it appears as follows: 

 

 

 

 

Note that if the Sheet Size is changed, for example, from A4 to A3, LogCheck re-calibrates the 

coordinates of each text entry to fit the new plot size. 

For the following title block parameters: 

 

 

 

 

 

 

 

 

 

 

 

 

 

An example of the title block produced by these settings is shown below: 
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10.10 The Tracks Tab 

The Tracks tab determines the columns and the appearance of the columns that will be 

displayed on a plot. Tracks can be inserted between existing tracks, added to the end of the 

existing tracks, or deleted. An example of the Tracks tab is shown below: 

 

 

In this example, there are two tracks: both with a data type of Geology; the first track plots the 

lithology as a pattern and the second track plots the Seam variable as a Value type. The second 

track will be plotted 10mm from the start of the Lithology. 

 

10.10.1   How This Form Works 

The top grid panel has columns for all the parameters that can be set for plotting a track. The 

bottom panel changes depending on which column in the top grid is currently selected. 

 

 

 

 

 

 

 

Selecting a column 

from the top grid 

alters the display in 

the bottom form 
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Setting values in the top grid updates the corresponding values in fields in the panel, and setting 

values in the panel fields updates the grid. The bottom section of the Tracks tab has the 

following panels that control settings in the top grid:  

• Display Type panel,  

• Display Options panel,  

• Horizontal Scale panel,  

• Vertical Scale panel and  

• Track Title panel. 

 

These panels are described in following sections. 

10.10.1.1 Scrolling the Grid Panel 

To view the remaining columns in the grid panel, drag the knob in the scroll bar. 

 

 

 

 

 

 

As this panel is scrolled, the first four columns are frozen (Xorig, Width, Data Type, Variable); the 

remaining columns are moved left. Scrolling one column to the left, the panel now looks like: 

 

 

 

 

 

Notice that the Disp_Type column has “disappeared”, and the remaining columns to the right 

are moved to the left. 

 

10.10.2   Setting Track Position and Width 

The position and width of a track can be set with the XOrig and Width columns. These values 

can be typed directly in the grid. 

10.10.2.1 XOrig 

The horizontal offset from the hole on the left edge on the plot. 

10.10.2.2 Width 

The width in mm of the track – this can be typed directly in the top grid. 

First four columns 

are fixed. Drag the scroll 

bar. 

Layer is now the 

fifth column. 
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10.10.3   Selecting the Data Type and Variable 

The Data Type of the track is selected from a  drop-down 

box as shown on the right:  

 

 

 

 

 

 

The variable is specified by 

typing its name in the 

Variable column of the grid. 

A list of the valid variables 

can be obtained by pressing 

the F8 function key. 

 

 

 

 

 

If a non-existent variable is entered, the following message is displayed: 
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10.10.4   Selecting the Display Type of a Track 

The display of a track is determined by the Disp_Type column. The values available in the 

drop-down box are: Value, Description, Histogram, Line Trace, Boundary Depths, Unit 

Thickness, and Pattern. The display of data is determined by whether the data type of the 

variable is coded (for example, Lithology – LI) or numeric (for example LAS data – DENB). 

Display Type Coded Data - Strength Numeric Data 

Value and  

Pattern 

 

 

 

 

 

 

Variable: Lithology (LI) 

 

Variable: Tectonic Dip (TD) 

Description  

 

 

 

 

 

Variable: Strength (ST) 

 

 

 

 

 

 

Variable: Tectonic Dip (TD) 

Histogram  

 

 

 

 

 

 

Variable: Strength (ST) 

 

Variable: Tectonic Dip (TD) 
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Line Trace -  

 

 

 

 

Variable: DENB. 

Boundary Depth  

Variable: Lithology (LI) 

- 

Unit Thickness  

 

 

 

 

 

 

Variable: Lithology (LI) 

 

Variable: Tectonic Dip (TD) 
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10.10.5   The Display Options Panel 

The Display Options panel of the Tracks tab has sections that determine the way data is 

displayed in the plot. 

 

In the Display Options panel, the variables are: 

• Layer Name (Layer): The plot layer for the 

track. This is a user-defined layer name. 

In AutoCad’s TrueView, layers can be 

turned on or off.  If a layer is not 

specified, it goes on Layer 0. 

• Colour (Colour): the colour that the track will 

be drawn in. It can be either an Autocad 

colour number or, the colours specified in 

the LogCheck dictionary (eg, LI). 

• Fill Colour (Fill_Colour): The Autocad colour 

number for the histogram. 

• Combine Identical Adjacent Displays 

(Comb_Dupl): combine the identical 

adjacent displays. This is only available 

for coded data – it is disabled for numeric data. 

• Show Coal Brightness: display coal brightness. 

 

If the track variable is a text data type, the Text Justification options and Text Height field are 

enabled. 

For the Lithology variable, the example on the right 

shows: 

• The lithology displayed as a pattern, 

• Specifying the colour of a track using the colours in 

the Lithology dictionary – by setting the Colour field 

to LI, 

• Displaying the coal brightness. 
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10.10.6   The Horizontal Scale Panel 

The Horizontal Scale panel of the Tracks tab has sections that control the formatting of the 

horizontal scale for a track. The sections that are enabled vary depending on the data type and 

display type being plotted: 

• If the track is a coded value, the Coded Data panel is enabled.  

• If the track is numeric data, the Numeric Data panel is enabled.  

• If the track display is set to Pattern, the horizontal scale is not relevant, and the entire panel 

is disabled. 

 

 

 

 

 

 

 

 

 

 

10.10.7   The Coded Data Panel 

The Coded Data panel of the Tracks tab  is only valid if the Disp_Type is set to Histogram or 

Value. In these cases, the options available are: 

• All Codes:  All codes from the dictionary will be used. 

• Plotted Codes:  Only those codes used in the plot will be used. 

• Specify:  Only those codes that are specified will be used to construct the histogram. 

In the example below, if the track variable is Strength (ST), and the 

Disp_Type is Histogram, the relative axis of the histogram can be specified 

with a comma separated list of values, in this case the order determines the 

height of a bar: 

 

 

 

 

Depending on 

the data type 

and display 

type, only 

one of these 

two panels 

will be 

enabled. 
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The example below shows that for Variable LI, where Disp_Type is Value, and Text 

Justification set to Value, the Coded Data panel is enabled: 

 

 

 

 

 

 

 

 

 

 

 

 

The Coded Data options can also be set in the 

grid, by selecting one of the items in the drop-

down box, as shown on the right: 
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10.10.8   The Numeric Data Panel 

The Numeric data panel of the Tracks tab forms part of the Horizontal Scale panel, and allows 

the left and right values of the horizontal axis to be specified for tracks with numeric data. For a 

Line Trace, it is necessary to specify the minimum and maximum values of the axis. These can 

be specified in the LVal and RVal columns. LVal specifies the variable value at the left end of 

the track, RVal specifies the variable value at the right end of the track.  

The LVal and RVal values must be specified – the axis is only displayed if the Plot Horizontal 

Scale box is checked. This is described on the following page. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Setting the LVal and RVal fields in the panel will update the display in the grid. 

1. Type the 

values here. 

2. Values  

displayed in 

grid. 
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10.10.9   Specifying the Horizontal Scale 

The horizontal scale bar can be displayed at the end of a plot. If the Plot Horizontal Scale Bar 

option is checked, the remaining fields in this panel are enabled 

 

 

 

 

 

 

 

Where one track is overlaid on top of another, the Vertical Offset can be used to move the scale 

of one of the variables further down the plot so that they don’t overwrite each other. In the 

example below, the Vertical Offset for the GRDE LAS variable was set to –12.5 mm: 

 

 

 

 

 

To display the scale:  

• Check the Plot Hor. Scale box, 

• Alter the Text Height (eg 4 mm) 

and 

• Click the Code option. The 

values will then be displayed in 

the grid. 
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10.10.10  The Track Title Panel 

The title of a track can be displayed on the plot in the 

Track Title panel, which is in the Tracks tab. The options 

are to not have a track Title, to use the Code or Description 

of the variable (as found in the dictionary), or to specify a 

title, as shown on the right. The parameters that can be set 

from this panel are: 

• Vertical Offset: the distance down the plot that the title 

will be printed. 

• Text Height: the height of the title in mm. 

• Text Angle: the angle at which the title will be drawn. 

 

A box can optionally be drawn around the plot, and its 

length optionally fixed to the page length. 

In the GEOLASPR plot parameter file, three LAS variables are plotted; in the example shown 

below of the Tracks tab, DENB and GRDE both use the Code as the Track Title, whereas the 

CADE variable is specified as CALIPER (MM). Note that for GRDE, the Title is offset by 5mm 

down the page, so it is not overwritten which is plotted in the same space as the DENB variable,  

 

 

 

This results in the following plot: 

Note that specifying the same values for XOrig and 

Width results in the tracks being overlaid on each 

other, as shown with the DENB and GRDE 

variables. 
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10.11 Adding, Inserting and Deleting Tracks 

Tracks can be added to the end of the existing tracks, inserted between existing tracks or deleted 

by accessing the Edit menu. To insert a track, select the Tracks tab and go to Edit > Append 

Rows, and a new track is added to the grid, as shown below: 

 

 

When a track is appended, it copies the values from the previous row down to the new row. 

However, for this track the LAS data is to be plotted. Click on the Data_Type column, and 

select LAS from the drop-down box, as shown below: 

 

 

 

 

 

 

Appended track. 
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10.12   Summary of Tracks Parameters 

The parameters that can be set in the Tracks tab are: 

• Box: Draw a box around the track and its title. 

• Box_Fixed: Fix box length to page length. 

• Coal_Only: Display only coal zones. 

• Coded_Scale: Horizontal scale type (All, Plotted or Specify). 

• Colour:  The Autocad colour number for the track. 

• Comb_Dupl:  Combine the identical adjacent displays. 

• Data_Type:  The data type of the track. This column displays a drop down box with 

the available data types. 

• Detail_On: Display coal brightness. 

• Fill_Colour:  The Autocad colour number for the histogram and line trace fill the track. 

• HGrat_Hgt: Horizontal graticule annotation height (mm). 

• HGrat_On: Option to plot the horizontal graticule. 

• HGrat_Step: Horizontal graticule interval (mm). 

• Layer:  The plot layer for the track.  

• Log: Use a logarithmic scale for the horizontal scale. 

• LVal, RVal: Left and right hand limits of the horizontal scale. 

• Scale_Hgt: Horizontal scale height of text (mm). 

• Scale_On: Show the horizontal scale. 

• Scale_Title: Optional title for the horizontal scale. 

• Scale_Y: The vertical offset of the horizontal scale. 

• Specified_Codes: If Coded_Scale is set to Specify, the list of codes for the histogram. 

• VGrat_On: Option to plot the vertical graticule. 

• Title: Title for a track (none, code, description or specify) 

• Title_Y: Vertical offset of Title (mm). 

• Title_Hgt: Track title height (mm). 

• Title_Ang: Track title orientation (degrees). 

• Variable: The variable being plotted. 

• Width:  The width in mm of the track. 

• XOrig:  The horizontal offset from the hole on the left edge on the plot. 
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10.13   Plotting the LAS Data 

To plot the LAS data: 

1. Set up the track data for each LAS variable. For example,  

(a) In the Tracks tab, append a new track and set the Xorig and Width values. Here, 

the Xorig is moved to 30 mm from the origin, the width is changed to 125 mm. 

(b) Select LAS data as the Data_Type,  then the Variable can be changed to one of 

the LAS variables – in the following example, the DENB variable is typed in, 

the Disp_Type is set to Line Trace: 

 

 

 

 

 

 

 

 

2. Open the LAS data (File > Open > Hole Data and select LAS data from the Data Type 

drop down box), then go to File > Plot, and append the data to the existing plot. 

3. Activate TrueView and open the DXF plot file to view the plot. 
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Chapter 11  
File Structure 

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

� Understand the purpose and locations of LogCheck files. 

� Understand how LogCheck selects dictionaries, plot definitions, and 
graphic editor definitions. 

 

 

11.1  Introduction  

This chapter describes the directory (ie. folder) structure  that is used by LogCheck. It describes 

the location of the runtime files, the LogCheck program and the location and purpose of the 

different subdirectories that are used by LogCheck to store data. The terms Directory and folder 

are interchangeable. 

 

11.2  LogCheck Directories  

The LogCheck program uses directories for storing the: 

• dBASE Runtime program, 

• LogCheck program and documentation, 

• LogCheck working and temporary files, 

• The LogCheck user data. 

 

If any of these directories do not exist, the LogCheck program automatically creates them. 
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11.2.1 RunTime Program Directory  

LogCheck uses a cut- down version of dBASE Plus. This is called the dBASE RunTime Engine. 

This must be installed from its installation file before LogCheck can be installed. The user is 

able to specify the directory where RunTime is stored but generally they select the default of: 

  c:\Program Files\dBase\PLUS\Runtime    (for Windows 32-bit System).  

or 

 c:\Program Files (x86) \dBase\PLUS\Runtime  (for Windows 64-bit systems) 

Do not delete or alter any of the files in this directory. When receiving upgrades of LogCheck, 

the Runtime remains the same and generally does not need to be upgraded. In rare cases, a 

LogCheck upgrade will include a Runtime upgrade. In these cases the user will need to 

download a new version of the Runtime installation file and run it before LogCheck  can be 

upgraded. 

 

11.2.2  LogCheck Program Directory 

The user is able to specify the directory where the LogCheck program is stored but generally 

they select the default of c:\Program Files\LogCheck\Bin. Do not delete or alter any of the files 

in this directory.  

 

11.2.3  LogCheck Work Directory 

LogCheck creates two working directories to store working and temporary files. These may vary 

from computer to computer, but on Windows 7, examples of these are: 

  C:\Users\username\AppData\Local\LogCheck\Work 

  C:\Users\username \AppData\Local\LogCheck\Temp 
 

where username is the name under which the current user is logged onto the computer. 

Temporary files are those that will be deleted once LogCheck terminates. Working files are 

those that persist between LogCheck sessions. The user must have write access to these 

directories. Note that on computers running Microsoft Windows XP or older versions of 

Windows, these directories may reside in other locations. 

With Release 6.000 and onwards of LogCheck, the Work and Temp directories are stored in a 

different directory for each user logged on with a different user name. This enables each user to 

have a different set of default values saved from their previous sessions. 

 

11.2.4  LogCheck Data Directory 

On running LogCheck for the first time, the user is prompted for the name of directory where 

the data will be stored. This can be a directory on your hard drive or anywhere on your 

connected network. The default is c:\LogData. If the specified directory does not exist the 

program creates it.  
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The user can later change the 

directory from where LogCheck 

accesses its data by selecting  

Settings > Options from the LogCheck 

menu and then entering another 

directory name. This dialog is shown 

in the figure on the right. You can 

either type the name of the directory, 

or select the Browse button to choose 

from a list. 

For example, you can use this feature 

to locate working data on the local 

hard drive, and finalised data on a 

server. 

 

 

 

 

The user can even have a number of LogCheck data directories but the program will only access 

data in the one that is current. The figure below shows a typical LogCheck data directory 

structure: 

 

 

 

 

 

 

 

 

The diagram above shows three project folders (AVOCA, COALLOG4 and ERINA) and two 

folders (Dictionaries and PlotPara) that are provided for storing default values used by 

LogCheck. If the graphical editor is installed, there will be a third folder, GraphEditPara. The 

purpose of these folders is as follows: 

• The Dictionaries folder stores the default dictionaries for LogCheck,  

• The GraphEditPara folder stores the details of the LAS variables that are to be plotted in the 

graphical editor and  

• The PlotPara folder stores the default plot definitions required for LogCheck.  

These defaults are used if LogCheck does not find the required dictionaries and/or plot 

definitions in the current project. 
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11.2.5 Dictionaries Subdirectory 

Each dictionary consists of two files with names of the form: 

• Data Type Dictionary.dbf and  

• Data Type Dictionary.mdx.  

 

For example, the dictionary for the geology data consists of two files named Geology 

Dictionary.dbf and Geology Dictionary.mdx. The .dbf file contains the actual dictionary and the 

.mdx file an index to speed lookups in the dictionary. These files can be copied or deleted, but not 

renamed. Note that if you copy, delete or overwrite these files, you must do it for both of them. 

When LogCheck is searching for a dictionary for a particular data type it first looks in the 

directory of the particular data type within the current project. If there is no dictionary there, it 

searches the directory called Dictionaries sitting in the LogCheck data directory. For example 

when looking for the geology dictionary for the project AVOCA it would look for: 

  c:\LogData\AVOCA\Geology\Geology Dictionary.dbf 
 

and if this file does not exist it would look for: 

  c:\LogData\Dictionaries\Geology Dictionary.dbf. 

 
Users working for a single mining company with a number of projects will generally have a single 

dictionary for all their projects sitting in the Dictionaries folder whereas a consultant will often 

have different dictionaries for different clients and these will be stored in the client’s projects. Coal 

Quality Cementing, Geologists and UCS do not have dictionaries as they do not have coded data. 

For Geology data, there is also the provision to store seams and horizons in a separate Seams 

dictionary. This enables the user to have one Geology dictionary for all their projects stored in that 

folder and an individual Seams dictionary for each project stored in the Geology folder of each project. 

11.2.6 PlotPara Subdirectory 

One of the LogCheck data types is the Plot Definition data type. Once the user has entered a Plot 

Definition it can be used by the program for plotting the user’s Hole Data. Plot Definitions may 

be deleted, copied or renamed by deleting, copying or renaming these files. Plot Definitions 

sitting in the PlotPara subdirectory of the main LogCheck data directory can be used by all 

projects in the LogCheck data directory. For a particular Plot Definition there are four files: 

PlotDefinitionName.MEM The scale, sheet size and section information for 

PlotDefinitionName; 

PlotDefinitionName_Bars.DBF The depth and RL bar definitions for PlotDefinitionName; 

PlotDefinitionName_Titles.DBF The data for the title block for PlotDefinitionName; 

PlotDefinitionName_Tracks.DBF The definition of each of the vertical tracks, including 

the names of the variables to be plotted and how they 

are to be plotted, for PlotDefinitionName. 

11.2.7 GraphEditPara Subdirectory 

If the Graphical Editor is installed, default GraphEditPara Definitions can be set up in the 

C:\LogData\GraphEditPara folder. Each one consists of a single file with a .dbf extension. Once 

the user has entered a GraphEditPara Definition it can be used by Graphical Editor. A 

GraphEditPara Definition can be deleted, copied or renamed by deleting, copying or renaming 

one of these files.  
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11.3 Project Subdirectories 

Each LogCheck project has its own subdirectory in the LogCheck data directory. The 

subdirectory has the name that was specified for the project when it was created. A project can 

be deleted, copied or renamed by deleting, copying or renaming this directory. Currently, 

project names can only be a maximum of eight characters and must not contain blanks.  

Each project subdirectory contains a file named:  

project.mem Project Details for the project. Do not delete or rename this file. If this 

file is present, LogCheck recognizes this as one of its project folders. 

If it is deleted, it will no longer be recognized as a LogCheck folder. 

You can create other folders in the LogCheck data directory, however, 

LogCheck will ignore them without this file. 

If project.mem is deleted, it can be restored by creating a new project, copying across the data, 

deleting the old project and renaming the new project. After a new project is created, LogCheck 

creates the following subdirectories: 

Exports Text files and reports produced by LogCheck, 

Imports Dictionaries or data from other systems to be imported into LogCheck, 

LAS For downhole geophysical data, 

Plots Plots created by LogCheck, 

Work Working files created by LogCheck. 

 

Depending on what data is present for the project it may also contain the following 

subdirectories for hole data:  

Coal Quality Raw prox coal quality data, 

Casing Hole casing data, 

Cementing Details of any cementing, 

Defects Rock Mass Unit (RMU) and individual defect data, 

Drilling Drilling data such as drilling company and core size, 

Geologists Details of intervals logged by geologists, 

Geology Geological data such as lithology, colour, seam name, 

Headers Header data such as survey coordinates, 

PointLoads Point load data, 

Scanner Acoustic scanner analyses data, 

UCS Laboratory UCS measurements, 

WaterFlows Water flow data. 

 

Depending on what data is present for the project it may also contain the following subdirectories 

which have program control data for use by LogCheck when accessing Hole Data: 

GraphEditPara Graphical editor definitions containing names of the LAS traces, their 

horizontal scale and colour for the Graphical Editor; 

HoleSet Hole Set Definitions such as hole lists, section lists or lists based on a 

query; 

Interval Interval Definitions based on a query, such as cored interval or the 

interval within a certain number metres of the roof of a specified seam. 

PlotPara Plot Definitions such as plot scale and variables to be plotted; 
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An example of the folders in a project subdirectory is shown below in the left pane and the 

contents of the Geology folder in the right pane: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11.3.1 Hole Data Subdirectories 

The hole data subdirectories are: Headers, Drilling, Casing, Cementing, Geologists, Geology, 

WaterFlows, Defects, PointLoads and Scanner. The hole data subdirectories contain files for 

each drill hole named: 

holename.DBF the coded data for the hole named holename; 

holename.DBT the comments for the hole named holename 

  (unless the particular data format  does not have any 

comments fields). 

Each hole data subdirectory may also contain the appropriate lookup dictionary files. 

Hole data can be deleted, copied between projects or machines or its hole name changed by 

renaming these files. Depending on the internal data format that LogCheck uses, the maximum 

size for a hole name can be between 8 and 16 characters and must not contain blanks, though 

this restriction means that the user can take backup copies of the files and give them names such 

as holename copy.dbf and leave them in this subdirectory and LogCheck will ignore them. 

These are not “official” 

LogCheck folders – it 

shows that the user can 

have other folders within 

a project, that are not 

maintained by 

LogCheck. 
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Currently, the filenames of all data types for a hole are the same therefore care must be taken when 

moving files ensuring that they are placed in the directory for that data type in the destination 

project. Where there is a .dbf file and a corresponding .dbt file it is essential that any deletion, 

renaming or moving is applied to both files. If not, the comments for the hole will be lost. 

For example, for each hole, there can be a file in the Headers, Drilling and Geology folders, 

each with the same name – their contents being defined by the folder they occur in. For 

example, the diagram on the left shows the .dbf and .dbt geology files for holes AVC030C, 

AVC031C, AVC032, AVC033, and the equivalent files for the Headers folder on the right. 

11.3.2 Exports Subdirectory 

The Exports subdirectory is the default directory for exporting data. The files in this 

subdirectory have the following extensions: 

.TAG Sample tags for putting in sample bags, 

.CSV Text listings in comma delimited format for exporting data to spreadsheets, 

.TXT Text listings. In Tab delimited format, they can be used for exporting to word 

processors or spreadsheets. In fixed width format, they can be used for reading in a 

text editor, 

.DMP Dictionary listings in MineScape/GDB format for exporting to MineScape /GDB, 

.DBS Hole data listings in MineScape /GDB format for exporting to MineScape /GDB, 

.DIC Dictionary listings in Minex format for exporting to Minex, 

.DAT Hole data listings in Minex format for exporting to Minex, 

.DCL Dictionary listings in Vulcan format for exporting to Vulcan, 

.DBL Hole data listings in Vulcan format for exporting to Vulcan. 

 
This subdirectory and these extensions are the defaults used by the program. The user can 

specify other subdirectory and filenames with other extensions when actually exporting the data. 
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11.3.3 Graphical Editor Definition Files Subdirectory 

This folder contains Graphical Editor Definitions which specify the LAS variable names, and 

values of the left edge, right edge and colour to be plotted in the Graphical Editor. There is a 

separate file with a .dbf extension for each graphical editor definition. 

11.3.4 HoleSet Subdirectory 

Another of the data types in LogCheck is a Hole Set Definition data type. Once the user has 

entered a Hole Set Definition it can be used for opening a specific set of holes which can then 

be plotted, reported on or exported. Hole Sets are defined in one of four ways: by picking off a 

list, by importing, by defining a section or by setting up a query. For a particular Hole Set there 

are two files: 

HoleSetName.MEM information defining the type of the Hole Set called 

HoleSetName; 

HoleSetName.DBF information defining the holes in the Hole Set called 

HoleSetName. 

Hole Set Definitions may be deleted, copied or renamed by deleting, copying or renaming these 

files. Note though that Hole Set names must not contain blanks. 

11.3.5 Imports Subdirectory 

This is the default directory used by LogCheck when importing dictionary and data files from 

other systems. The user can specify other directories when importing the data. 

11.3.6 Interval Subdirectory 

Once the user has entered an Interval Definition it can be used for opening a specific interval 

within holes which can then be plotted, reported on or exported. Such intervals may be, for 

example, the cored interval or the interval within a certain number metres of the roof of a 

specified seam. 

For a particular Interval definition there is only one file: 

IntervalName.MEM Information defining the Interval called IntervalName. 

Interval Definitions may be deleted, copied or renamed by deleting, copying or renaming the 

file. Note though that Interval Definition names must not contain blanks. 

11.3.7 LAS Subdirectory 

Downhole geophysical data used by the program must be in LAS format. The directory where 

these files are stored for a project is specified by the user in the Project Details of the project. If 

the user does not specify a LAS directory then the program uses this subdirectory of the project 

directory.  

When looking for LAS data the program not only searches the directory but all levels of 

subdirectories below this directory. The only limitation is that the name of the combined 

subdirectories below this directory plus the filename must be less than or equal to 32 characters 

and must not contain any blanks. 
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After the user has accessed any LAS data, the LAS subdirectory will also contain the files: 

LAS Dictionary.DBF a dictionary of the variable names used in the LAS files; 

LAS Dictionary.MDX an index into the dictionary of variable names. 

 

These files are automatically created or updated whenever the user opens a LAS file in LogCheck. 

11.3.8 PlanPara Subdirectory 

The PlanPara subdirectory contains parameters for drawing hole plans – there is only one file: 

PlanParaName.MEM information defining the hole plan parameters. 

11.3.9 PlotPara Subdirectory 

The PlotPara subdirectory of a particular project contains the same three files as the PlotPara 

subdirectory that is located under the LogCheck folder.  Data in the project PlotPara 

subdirectory takes precedence over the one in the LogCheck folder. As for the default sets, there 

are four files for each PlotPara definition: 

PlotDefinitionName.MEM The scale, sheet size and section information; 

PlotDefinitionName_Bars.DBF The depth and RL bar definitions; 

PlotDefinitionName_Titles.DBF The data for the title block; 

PlotDefinitionName_Tracks.DBF The definition of each of the vertical tracks. 

 

11.3.10   Plots Subdirectory 

This is the default directory used by LogCheck when creating plots. The user can specify other 

directories for storing a plot when actually creating it. 

11.3.11   Work Subdirectory 

The work subdirectory contains the working files that are created and maintained by LogCheck. For 

example, the files SEAMS.DBF and SEAMS.MDX contain a summary of the top and bottom of 

each seam in each hole as well as the file modification time and date for the geology file from 

which the information was obtained. When the user requests a seam summary the program only 

needs to update those holes where the geology data has been modified since the last seam 

summary. Where there are a large number of holes such as a couple of thousand this can reduce the 

time taken to generate a seam summary from 3 or 4 minutes to a matter of seconds. 

The user can delete the files in this subdirectory if necessary, for example, if they become 

corrupted.  When deleting a file the user should also delete all other files in the directory with 

the same filename but differing extensions. If these files are not there, LogCheck will first need 

to recreate them, which can be a little time consuming if there are many holes in the project. 
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Appendix A – Query Language Specification  

 

 

A1. Introduction 

Data in LogCheck can be selected by using query selection statements. The syntax or rules used 

to specify a query are those of the DBL (dBASE language) and can be used for selecting records 

from a database table. 

The query selection syntax is used in the following places in LogCheck: 

• In hole set definitions, when selecting the holes by query. 

• Interval definitions. 

• Filtering data in LogCheck summaries. 

• Definitions for specifying a level for aligning the vertical position of holes in a section. 

 

An example of using a query to select a group of holes is as follows (see Chapter 5). In this 

example, Seam is the variable name at the heading of the Seam/horizon column when editing 

Geology data. This query will include all holes where seam "WK2" has been logged. Note that 

character strings such as "WK2" requires the double quotes. 

 

 

 

 

Part of a screen that uses a query to select an interval is shown below (see Chapter 5). This example 

selects intervals where the top interval is 1.0 m above a unit that is a seam (SEAM <> " "), and not a 

horizon (ie, CALCTHICK > 0): 
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As an example of using a filter, if a Seam Summary is opened, go to Tools > Filter and a dialog 

requesting a filter expression is displayed. This dialog allows you to restrict the rows that are 

displayed to those that satisfy the filter expression – in this example, only seams that start with 

"WK2" will be displayed after this filter is applied. 

 

 

A query can be used to specify the vertical alignment of a plot definition. The following 

example is from the Section tab of a Plot Definition file and aligns the holes on a section so that 

the top of the WK2 seam is at the same level for each hole on the section. 
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Appendix A2 – Writing Selection Queries 

Selection queries involve some kind of restriction on the data that is selected. This is done by 

specifying some kind of restriction on a variable – a variable is one of the columns on a 

database table, for example the column named Seam in Geology data. 

Example 1. In a Hole Set Definition, to select only holes that have a seam that starts with "GU0": 

 SEAM = "GU0" 

 
The column names and text values are not case sensitive, for example, both Seam and seam 

would also work. Also, when comparing numeric values, the quotes ("…")  are left off numeric 

values. Operators that can be used to select data include: 

• Comparison operators, 

• Logical operators, 

• dBASE functions. 

 

The Comparison Operators 

The comparison operators consist of equality and relational operators as follows: 

Equality Operators Relational Operators 

== Exactly equals < Less than 

= Equal to, or begins with > Greater than 

<> or # Not equal <= Less than or equal 

  >= Greater than or equal 

 

The following examples use the thickness ("Thick") or seam columns in hole seam summaries.  

Example 2. Select seam intervals where the thickness equals 0.20: 

 Thick = 0.20  
 

Example 3. Select seam intervals that are exactly the GU0 seam (include a blank after the "0"): 

 SEAM = "GU0 " 

 
Example 4. Select seam intervals that match anything starting with "GU0" (note that there is no 

blank included here): 

 SEAM = "GU0" 

 
Example 5. Select seam intervals where the thickness is less than 0.20 (does not include 

intervals that are 0.20):  

 Thick < 0.20  

 
Example 6. Select seam intervals where the thickness is greater than 0.20 (does not include 

intervals that are 0.20): 
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 Thick > 0.20  

 
Example 7. Select seam intervals where the thickness is less than or equal to 0.20 (also includes 

intervals that are 0.20): 

 Thick <= 0.20  

 
Example 8. Select seam intervals where the thickness is greater than or equal to 0.20 (also 

includes intervals that are 0.20):  

 Thick >= 0.20  
 

Example 9. Select seam intervals where the thickness does not equal 0.20.  

 Thick <> 0.20  

 

Note: when a column containing a date value is used, the date is converted to a string. This 

means that if a column in LogCheck contains a date such as 1/6/2010, it is converted to 

"01/06/2010", so in a query expression, any single day or month values require a leading "0". 

For example: date < "01/06/2010" should be used, not: date < "1/6/2010".  

 

The Logical Operators 

The logical operators are AND, OR and NOT. Compound conditions are formed by connecting 

two or more conditions using the logical operators. The rules of precedence for operators, from 

highest to lowest are as follows: 

1. All comparison operators 

2. NOT 

3. AND 

4. OR 

 

You should use parentheses not only to document your logic, but also the significant differences 

in the results with/without parenthesis. 

Example 10. Select all holes with seam GU0, and where this seam  is at a depth of greater than 

100m: 

 SEAM = "GU0" AND Depth > 100 
 

Example 11. Select all holes with seam GU0 or GU1, and this seam  is at a 

depth of greater than 100m: 

 SEAM = ("GU0 " OR "GU1 ") AND Depth > 100  
 

Example 12. Select all holes with seam GU0 ( no matter the depth), or  the 

seam is GU1 at a depth of greater than 100m: 

 SEAM = "GU0 " OR "GU1 " AND Depth > 100  
 

Example 13. Select all holes with seam GU0, and this seam  is at a depth of greater than 100m 

and less than 120m: 

 SEAM = "GU0" AND Depth > 100 AND DEPTH < 120 
 

Note the difference in 

what will be selected  

between queries with 

parentheses and those 

without. 
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The dBASE Functions 

There are many dBASE functions can also be used in a query to select data. The most 

commonly used functions that operate on string are as follows: 

• Right(variable, number): Return the rightmost number of characters; 

• Left(variable, number): Return the leftmost number of characters; 

• Len(variable): Return the number of characters in the variable. 

• Trim(variable): Trims any leading or trailing blanks from a variable. 

 

Example 14. For a Hole Set definition named CORED, select headers for all holes where the 

hole name ends in a "C": 

  
 

 

 

In this case the Trim function firstly removes any blanks from the file name to achieve the 

match, then the Right function only returns those holes whose name ends in "C". 

Example 15. When viewing a sample summary, use a filter to only display sample numbers 

whose length is exactly 8 characters: 
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Appendix B – Standard Plot Definitions  

 

B1. Introduction  

LogCheck comes with a standard list of plot files. These include: 

• A seams only plot at 1:20 
• Entire hole with Geophysics (Density Gamma and Calliper) 

• Stacked plots of individual holes in A4 and A3, at scales of 1:20, 1:100, 1:200. 

• Section plots without horizontal scale (ie sit 10mm apart for a fence diagram) on A4 

and A3 at 1:100 and 1:200. 

The plot definitions that produce these are described below: 

What Description Plot Definition Vertical 

Scale 

Paper 

Size 

Seams Only Seams-only plot in 

one plot file. 

LC_SEAM 1:20  –   

Entire Hole + LAS Tracks: Lithology + 

LAS in one bar and 

one plot file. 

Orientation: portrait 

LC_GEOLAS  –   

LC_STACK_A4_20 (5m/col) 1:20 A4 

LC_STACK_A3_20 (7m/col) 1:20 A3 

LC_STACK_A4_100 (25m/col) 1:100 A4 

LC_STACK_A3_100 (35m/col) 1:100 A3 

LC_STACK_A4_200 (50m/col) 1:200 A4 

Stacked Plot Single hole, lithology 

in multiple bars; 

multiple plot files. 

Tracks: Lithology, 

Seam, SampNumb. 

Orientation: portrait 

LC_STACK_A3_200 (70m/col) 1:200 A3 

LC_SECTN_A4_100 

(25m/col) 
1:100 A4 

LC_SECTN_A3_100 

(35m/col) 
1:100 A3 

LC_SECTN_A4_200 

(50m/col) 
1:200 A4 

Section Plot 

 

Stratigraphic fence 

plot of seams. 

Requires hole set and 

interval definitions. 

Orientation: 

landscape. 

LC_SECTN_A3_200 

(70m/col) 
1:200 A3 
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B2. The Seams-Only Plot Definition 

The Seams plot definition (LC_SEAMS) plots the selected seams, where the top of the selected 

seam is all displayed at the one level, for a single hole. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The steps required to generate this plot are: 

• Set up an interval definition (File > New > Interval Definition). An example is shown on the 

following page. 

• Open the data for the required hole (File > Open > Hole Data) and select the required 

interval definition. 

• Generate the plot (File > Plot) and select the LC_SEAM plot definition.  

 



APPENDIX B. STANDARD PLOTS 

170  LogCheck Manual 

The definition for seams is contained in the SEAMS interval definition, as follows 

 

 

:  

In this definition, all seams are picked up where the seam thickness is non-zero; the second part 

of the interval selection (calcThick > 0) is necessary to exclude any horizons. 
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B3. Entire Hole with Geophysics 

The standard plot LC_GEOLAS plots the entire hole as one bar with the LAS data plotted in 

tracks (DENB, GRDE, CADE) to the right, for example: 

 

 

The Tracks tab of this plot is as follows: 

 

The steps required to generate this plot are: 

• Open the Geology data for the required hole (File > Open > Hole Data) and select the 

required drill hole. 

• Generate the plot (File > Plot), select the LC_SEAM plot definition and save the plot file.  

• Open the LAS data (File > Open > Hole Data and select LAS data from the Data Type drop 

down box), then go to File > Plot, and append the data to the existing plot. 
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B4. Stacked Plots 

The stacked plot definitions plot hole data at scales of 1:20, 1:100 and 1:200 in multiple bars, 

for as many plot files as are required, on A4 or A3 sheets. The following example using hole 

DDH001 was produced using LC_STACK_A4_20, plotted on an A4 sheet: 
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The following figure shows details of the LC_STACK_200 plot, with the sample number on the 

left of the column, and seam on the right: 

 

 

The Tracks tab of the stacked plot definitions is as follows: 

 

The steps required to generate this plot are: 

• Open the data for the required hole (File > Open > Hole Data) and select the required hole 

set or interval definition. 

• Generate the plot (File > Plot) and select one of the LC_STACK  plot definitions.  
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B5. Section Plots 

A LogCheck section plot draws a stratigraphic fence plot, by correlating seams between the 

holes specified in a hole set definition, interval definition, or combination of the two. There are 

four standard section plots, as detailed in the table in the introduction to this appendix:  

• LC_SECTN_A4_100 (25m/col) 

• LC_SECTN_A3_100 (35m/col) 

• LC_SECTN_A4_200 (50m/col) 

• LC_SECTN_A3_200 (70m/col) 

 

This standard plot definition draws at a vertical scale of 1:100, and plots to an A3 sheet. In the 

Sections tab of this plot definition, the Vertical Alignment is set to Hole Elevation.  

In the Border tab, the Offset of Top Left Corner from Top of First Hole on Left may need to be 

adjusted for all holes to appear within the plot border. The following plot used a vertical offset 

of 70 mm and horizontal  offset of -70 mm: 

 

The steps required to generate this plot are: 

• Open the data for the required hole (File > Open > Hole Data) and select the required hole 

set, interval definition, or combination of hole set / interval definition. 

• Generate the plot (File > Plot) and select one of the LC_SECTION  plot definitions.  
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Appendix C – Patterns  

The standard patterns available in LogCheck are as follows: 
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Appendix D – Fills  

The standard fills available in LogCheck are as follows: 
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Appendix E – Colours  

 

 

The AutoCAD colours are as follows: 
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